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1 Content Components

1.1 Ad-Coming Soon

Any combination of background image, text, and button displayed in a tiled (Grid) layout.

Usage:
e Grid display; background image only; background image + text (no link); background image
+ text + CTA button (link)
o Not suitable for lengthy text — it is intended for brief headings and sub-headings.

More info:
e The Ad-Coming Soon is one of the more versatile components.
e This component must be used in the Grid component. The Grid is first created in
Experience Editor, then the Ad-Coming Soon component is added to one of the Grid tiles.
¢ Two size variants: Tall and Short. Tall is suited for tiles that extend the full height of the
Grid. In the Tall variant, if a CTA selected, the Top Header and Sub header are hidden.
e The link is always a button, not a text or image link

Sub-component: CallToActionButton (optional)

Example 1: Text and image, no link

Featured in MSUToday

DELIVERING FASTER RESULTS:
MSU researcher develops new COVID-19 test FEATURED IN MSUTODAY

Example 2: Text, image and button link

5|Page
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Bottom Sub Header

CTA for Ad

Example 3: Text and image, no link

Top‘»Sub header Line
| header Lineygy

= ~0
/ = s

sy —

BOTTOM HEADER

Bottom Sub Header Line 1 Bottom Sub Header Line 2

6 |Page



University Communications, Michigan State University Sitecore CMS Components User Guide

STEPS — Add or modify content (data) for the component:

In Content Editor:

1. In Content Editor Tree, navigate to page’s Page Components folder:
a. To ADD new component: right-click Page Components folder, select Insert > Ad-

Coming Soon, and give it a unique name
b. To EDIT existing component: click Page Components folder to expand, and select

Ad-Coming Soon component
In right pane, modify fields in the Content section:
2. Image (required) — add background image (select from Media Library)

3. Eyebrow — add text and choose desired position from dropdown

4. Top Header, Top Sub-Header
i. If componentis placed in a Tall Grid tile, Top Header and Sub header are not

displayed.
ii. If component is placed in a Short Grid tile, and if both Top and Bottom fields are

entered, only Eyebrow and Bottom fields are displayed.

5. Bottom Header, Bottom Sub-Header

Top Header:

Top Header

Top Sub-Header:

Top Sub header Line 1
Top Sub header Line 2

Bottom Header:

Bottom Header

Bottom Sub-Header:

Bottom Sub Header Line 1
Bottom Sub Header Line 2

6. Add a CTA button (optional) — refer to the section below for instructions
a. After adding the CTA sub-component, select CallToActionButton from dropdown
(must also create the CTA sub-component — instructions below)
b. To remove CTA button without deleting CTA sub-component, select “None” in

dropdown.
7. Gradient — choose from dropdown

8. Text Alignment — choose from dropdown

7|Page
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9. Checkboxes — optional

10. SAVE
11. NEW Ad-Coming Soon component only:
a. In Experience Editor, add Grid component if one does not already exist.
b. In the Grid, add Ad-Coming Soon component to one of the tiles. Height variant is
determined by the tile size into which the Ad-Coming Soon component is placed:
i. Tall —full height of the Grid. If CTA selected, Top Header and Sub header
are not displayed
ii. Short — If both Top and Bottom fields are entered, only Eyebrow and Bottom
fields are displayed
c. SAVE and close EE tab
In Content Editor:

12. Optional: Select the page in the content tree and Preview to verify changes — on Publish
ribbon, select Preview

13. Publish the page component.

14. Verify changes in a browser.

1.1.1 Create/Select a CTA

More Info:
e A CTA (Call to Action) sub-component can be either local or global.
e |[f alocal CTA exists, the Ad-Coming Soon component’s CTA field dropdown list will ONLY
display the local CTAs available for selection.

STEPS:

Click “None” to remove the CTA button from the Ad-Coming Soon page component without
deleting the CTA sub-component.

CTA: @ [none]
v ctal
ctal v

If no local CTAs exist, clicking the Ad-Coming Soon CTA field’s dropdown displays the Tree and a
CTA button destination can be selected.

Deleting local CTAs displays the Tree and allows selection.

8 |Page
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CTA: @ [none]
4 [ sitecore
4 & Content
#) Home
Gradient alue]: » 2 Global Configurations
> @ MsU
L »  Forms
» [ Layout
Text Alignment ard ; » [ Media Library
b &y System
Center Align » [E] Templates

To create a local CTA sub-component:

1. Right click the Ad-Coming Soon component in the tree. Select Insert > CallToActionButton
and give it a unique name (does not display on page).

B DQ Media Video

4 i Hero Bapner 4 (J MSU
Insert » .4 CallToActionButton

e _oll7aa

Search 3
4 {J MSU Component: inserkizomitemplte

» ¢J MSUCalltoaq 3 Duplicate
] MSU Fuents R Delete

2. In Text field, enter button text — this is the button label, i.e. text that displays on the button

3. In Link field, indicate button destination, can be Internal or External.
If selecting an Internal page to link to, the page must have its “Include in Navigation”
checkbox selected.
a. Insert Link — (internal link) select page or other asset, enter Description (tooltip),
Target (“Active Browser” or “New Browser”), Alt Text. Click INSERT.
b. Insert Media Link — select file from Media Library, enter Description (tooltip), Target,
Alt Text. Click INSERT. (Can upload a file during component editing)
c. Insert External Link — enter Link Description, URL (fully-specified), Target, Alt Text.
Click INSERT.
d. Insert Anchor

Text:

READ MORE

Link:

Insert link Insert media link Insert external link Insert anchor In

/MSU/MSU/Home/academics
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4. Enter Campaign information (optional)

5. SAVE - sub-component name will now display in CTA field of Ad-Coming Soon page
component

6. Inthe Ad-Coming Soon Banner page component, select a CTA from the dropdown — this is
the active CTA that will display on the page.

To create a global CTA sub-component:
1. Remove any local CTAs if they exist.

2. Click CTA dropdown and select a destination in the Tree
3. Save

10 |Page



University Communications, Michigan State University Sitecore CMS Components User Guide

1.2 Advanced Accordion
Display content in expandable panels
Usage:

More info:

e Advanced Accordion component can be used globally. The accordions can have rich text
content as well as tabs.

Example:
RANKINGS & RECOGNITIONS +
U.S. NEWS & WORLD REPORT RANKINGS +

STEPS: To add or modify the content (data) for the component:
In Content Editor:

1. In content tree, navigate to the Page Components folder of your page and select it.
2. To ADD a new accordion component: right click Page Components folder, select INSERT
> Advanced Accordion, and give it a unique name.
3. To CHANGE an existing accordion component: click Page Components folder to expand it,
click the Advanced Accordion component to change.
4. To ADD a content panel:
a. Right click the Advanced Accordion component and select INSERT > Accordion

Tab. Give it a unique name. Example: tab1

4 | ] DeQue3

4 [ page Components
4 Advancer Accnrdinn
: Insert » [ AccordionTab
= Accon
Bl Contex Search ) Insert from template ¢ |
vy Lontextu v
b @ HeroBa Duplicate Item name: Acc
a4 8 Delete )
Highlight Item path: /it
@) Imagerz & Rename
o- .
. Template: /sin
Introduc Copying »

e - Craatarl fram: fism

b. In the right pane, enter the Accordion Tab Title — this displays whether the panel is
expanded or collapsed. Text is automatically capitalized.

c. Enter panel content using the Rich Text Editor — click “Show editor” to begin. SAVE
tab when done.
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C.

Accordion Tab
Accordion Tab Title: /

Accordion One

Accordion Tab Content /

ow editor Suggest fix Edit HTML

Wivamus suscipit tortor eget felis porttitor volutpat Donac sollicitudin molestie malesuada. Vestibulum ac diam sit amet quam vehicula elementum sed

Ogcnac rutrum congue l2o 2get malesuada Donec rutrum congue 'eo 2get malesuads. Curabiur arcu erat, accumsan id impeardiet e, portiitor at sem. \
amet ligula.

Curabitur non nullz sit amet sl tempus convallis quis ac lectus. Prassent sagien masss, convallis 3 pellentesque nec. egestas non nisi. Curabitur alig

If you wish to add a Tab component under the Accordion Tab, select the desired accordion
tab in the content tree, right click and select INSERT > Tab Component. Give it a unique
name.

4 [ Advanced Accordion

3 Accordion Tab

S—) 32 W (W o
™ Accordion Tah with Tahs
' insert *» & TabsComponent
& Contextual d 5 P
= Search 1 Insert from tempiate
» ‘&) Hero Bannel s ST g -..2coreh
D Highlight () Duplicate
Template: /sitecore/!
(#] Image Facts ¥ Delete
B introduction = Rename Created from: [unknown
A Media Contz Copying  » Item owner: sitecore\A
> & Mixed Conte Sorting 4
» & Mixed Conte & Edit Accordion Tab
P & Mixed Conte ¢ Refresh

Accordion Tab Title:
> & Mixed Content 3 Col

To add tabs, follow the steps in the Tab Component section.

Note that ONLY TWO tabs can be added. If you add more than two tabs, only the top two in
the content tree will be used.

SAVE

NEW Advanced Accordion component only — in Experience Editor:

7. Add Advanced Accordion component and select the data source (the component created in

8.

Content Editor).
SAVE and close EE tab
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In Content Editor:

9. PUBLISH your changes.
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1.3 Advanced Mixed Content

A combination of image, video, heading and text with a button link.
Content is arranged in 1-3 columns, depending on number of column sub-components.

Usage:
e Home page
e Main section landing page, providing links to other pages in the section

More info:

e Mixed Content allows up to 3 columns of a combination of image, title, text and CTA (link).

¢ Image is optional. If a video is specified, an image is required (it is the video thumbnail that
displays before the video starts).

¢ AYouTube video can be specified, it displays in a lightbox (i.e. a popup window overlay).

e The Mixed Content page component has a minimum of 1 column and a maximum of 3
columns.

e The component uses the full width of the page’s content area (not full width of the viewing
screen). Column image size is reduced according to number of sub-components.

e Column sub-components display on the page in the order in which they appear in the Tree.

e This component is similar to the Cascade Framework Promotion row type.

Sub-component: Column

Example 1: 1 Column, image on left, with horizontal line
Source: MSU Academics page https://msu.edu/academics

' Majors, Degrees and
. Programs

We offer 200 academic programs across 17 degree-
aranting colleges. Discover undergraduate, graduate
and pre-professional offerings.

Example 2: 2-columns with images, no horizontal line

MIXED CONTENT EYEBROW

14 |Page


https://msu.edu/academics

University Communications, Michigan State University Sitecore CMS Components User Guide

Example 3: 3 columns with image, with horizontal line

LATEST NEWS

Champion for women in Student emergency Virtual commencement
science named provost funding options scheduled for May 16
Following a national search, MSU As part of the recently passed MSU will hold a virtual

President Samuel L. Stanley Jr., M.D., federal CARES Act, MSU will be able commencement celebration on May
named Teresa Kaye Woodruff as the to provide about $15 million in 16. The virtual event does not
university's next provost and emergency financial aid grants to replace an in-person ceremony, and
executive vice president for students. Grant applications are members of the class of 2020 will
academic affairs. She is currently now available for students. be invited to participate in a future
dean of the graduate school and in-person commencement.

associate provost for graduate
education at Northwestern.

Example 4: 3 columns, no images, with horizontal line
Source: MSU Students page https://msu.edu/students

Email Stuinfo Desire2Learn
Log in to your MSU account. Updates, quick links, questions for Everything you need to access MSU
Sparty. It's all here. Distance Learning.

Log in to Email Log in to Stuinfo Visit D2L Website

STEPS: To add or modify the content (data) for the component:
Note: If component is created in Content Editor, created columns reside as child items of the
component. If component is created in EE, created columns reside as siblings of the component in
the Content Editor Tree. In either case, the component behaves correctly.
In Content Editor — create the component:

1. Navigate to the page’s Page Components folder, right click and select Advanced Mixed

Content.
2.  Give it a unique name.

15 |Page
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ADD Column sub-component — repeat for each column.

3.  Right click Advanced Mixed Content component and select INSERT > Mixed Content

Column.
’ ] Ueuue ‘ o W, WouUNTTLIUTLW
» L] DeQue2 Item name: Advanced Mixe
4 | ] DeQue3 /
1s £l e
4 |[JJ Page Components Insert » Mixed Content Column
’ Advanced /gford Search [ 1 Insert from template
@ Advanced Mixed I Duplicate Created from: [unknown]
%8 Box CTA _
R Delete Item owner: sitecore\nkarin
& Colleges and Maj
C Rename
» &) Contextual Navig Mixed Content
Copying »
@ Department of In
Sorting 4
» Dept of Law Adve Eyebrow:
) ¢ Edit
» i) Hero Banner V2
[T1 Console

Highlight Angular
B4 Scripts ’

(J@ll Media Library  Workbox @ Refresh _

4, Give it a name.

5.  Inthe right pane add:
— Title — a heading that displays above the description and button
— Horizontal line — check to display a small green line between Title and Description
— Description — text content

6. Optional: Add a CTA. The Link Description is the label used on the button.

Select link type

For Internal link, select a page from the content tree

For External link, enter fully specified path

Description — button label (text that appears on the button)

Target — Active Browser (destination displays in same browser tab) or “New Browser”
(destination displays in new browser tab)

Click Insert

®PoO0TD

—h

16 |Page



University Communications, Michigan State University Sitecore CMS Components User Guide

Item 1D: 983CBESS-ASS0-4C01-A256-2C23F1ASIDAF)

Item name: Faatured video grande

Item path: [sitacore/content/ MSU/MSU/Home/Page Companents/Featured video grande
Templaze: Isivecore/templaces/Feature/Shared/Companents/Mixed Content « (JEE7BDCE-OCAF
Created from: [unknown]

item owner: stecoretbarnes

Mixed Content ~

Eyebeow

Eyebrow

| Is Image On Left - This is used in single column version only

Image Size - This is used in single column version only:

7.  Eyebrow — optional heading about the component. This field is optional and can be left
empty.

8. If you wish to have a Green Horizontal Line separate the Title and Description, select the
“Horizontal Line” checkbox.

Col Two Descrpten
VIVEMUS SUSCIPE trtor eget fels portitor volutpat Veltibuum ac diam sit amet quam vehicula elementurn S=d sf am=1 du. NUEa parttiter accur

Vivamus suscipt tortor eget feks porttdor volutpat Dahec solicitudin molestie malesuada Pellentesque in ipsumn id oro porta dapibus

A
ftlink r 11 exty o saript

MSUMSU Home/DeQue 1

9. Image - click Browse and select an image from Media Library.
An image is required if specifying a video — it is the video’s thumbnail.

10.  YouTube Video ID: enter the YouTube ID (e.g. H8TBxPIGIUQ)

This is the code found after “https://www.youtube.com/watch?v="in a YouTube URL.
Example: https://www.youtube.com/watch?v=H8TBxPIGIUg

17 |Page
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11.

12.

Make sure you have included an image as this will be used as the thumbnail.

trategy Pages - Copy Docs/07 RessarchAmages/0id/Globalimpactinisative

Is image on left — If creating a single column component, check this box to have image
display on the left, uncheck to display image to the right of text and button.

Cartert [0
@’ Mixed Content 1 Co R

SAVE the column component.

In Experience Editor — place the Advanced Mixed Content component on the page:

13.

14.

15.

16.

Click “Add a new component” icon
Click the “Add here” text that suits the location of the component
Choose “Advanced Mixed Content” from the Rendering tray

Select the number of columns required for the component.

18 |Page
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Control Properties O X

eIy

Number of Columns [sta

One v
Two

Three

=T g

phMainContent

Data Source [

FOWse Build query Paste query Clea

/sitecore/content/MSU/MSU/Home/DeQue3/Page Components/Advanced Mixed Content

L En - J

17. Select each column area in turn — click “Add here” for the desired column.

PRESENTATION EXPERIENCE VERSIONS OPTIMZATION IEW

Charges to a component with effect tracking will reset tracking for the component. X
Mauris blandit aliquet elit, eget
tincidunt nibh pulvinar a.

+ Add nore

EYEBEROW COMPONENT

+ Add hare + Add here

18.  Choose “Mixed Content Column Partial Width” from the tray
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Select a Rendering

ng will reset trg

Select the rendering that you want to use. Click Select to continue.

Partial Width

APONENT

Open the Properties dialog box immediately. E Cancel

19.  Select the appropriate column in the Advanced Mixed Content component as the data
source.

Bl gelect the Associated Content

Select the content that you want to assodlate with the rendering and use as the data source,

Select an existing content item,

- mponent

b B Adunced

4§ Advanced Mixed Content

- Cancel
«8-cmQ1.szurawebsites.net/sitecore/shell/default. aspxTxmicontrol =Sitec,

20. Repeat these steps until all columns have been populated with content.

21. Close the EE tab and return to Content Editor.
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In Content Editor:

22.  Optional: Preview the page and verify changes made — on Publish ribbon, select Preview

23.  Publish the Advanced Mixed Content component.

24.  Verify changes in a browser.
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1.4 Aside
Description
Usage:

More info:

Example:

STEPS:

Sitecore CMS Components User Guide
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1.5 Box CTA

Simple Box CTA: Text and link displayed over a dark green box, with or without an arrow
icon, in a tiled (Grid) layout.

Social Box CTA: Text and social media links displayed over a dark green box in a tiled
(Grid) layout.

Usage:
e Grid container
¢ In the footer of most pages, in combination with the Stay Connected (Subscribe)
component
¢ Not suitable for lengthy text.

More info:
e This component must be used in the Grid component.
e Social Box CTA is used in conjunction with the Newsletter Sign Up (which uses a grid).
o Before the Box CTA component can be created, it must first be added to the Grid
component in Experience Editor as one of the Grid tiles.
e Background is dark green and cannot be changed.
e Simple Box CTA
o No social icons are selected
o Can specify Heading and Sub-Heading
o CTA Label is required but not displayed
o Can optionally displays an arrow icon
o Entire box acts as a link — click anywhere
e Social Box CTA
o One or more social media icons are selected from a listbox
o Can specify Heading
o Sub-Heading, CTA Label and Arrow icon are ignored (i.e. not displayed)
o Social icons are the links, cannot click anywhere else on the box.
e Social icons are selected from a list residing in sitename > Components > Social Media
Links (the site’s global components, maintainable by content authors).

Example: Test page, with and without the Arrow icon

MSU STUDENT LIFE MSU STUDENT LIFE

Learn more about MSU
Learn more about MSU Student Organizations
Student Organizations (-]

In the footer of most MSU pages, in conjunction with the Stay Connected (Signup) component:
https://msu.edu/
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Connect With Us

00000

STEPS: To add or modify the content (data) for the component:

1. Ifthisis a NEW Box CTA page component, it must first be added to the Grid container:

In Content Editor, select the page in the Tree

Navigate to Experience Editor — Publish ribbon > Experience Editor

Create a Grid component if needed

Click an empty Grid tile, click “Add here” and select “Box CTA” component

Select an existing Box CTA component or name a placeholder (empty) component
Save

Close the EE tab and return to Content Editor tab

N

2. In Content Editor Tree, navigate to page’s Page Components folder

3.  Select the appropriate Box CTA component — it will be empty (no content) if just created in
Experience Editor.

In the right pane, modify fields in the Content section:
4. Header, Sub Header

5. CTA Link —insert a link (Internal or External), CTA Label and Link Description do not
display on the page

CTA Details

Header:

CTA Box Header L1

CTA Box Header L2

Sub-Header:

Sub Header L1

Sub Header L2

CTA Label

CTA Label

CTA Link:

rsert link rsart media link art @xternal link Insert a1 T nsert emal rsert lavascnipt Follow

/MSU/MSU/Home
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6. Display Arrow Icon — check box to display the circle/arrow icon with the link

|

CTA Link:

/MSU/MSU/Home

Social Links:

#! Display Arrow Icon

7. To create a Social Box CTA, use instructions below to add or edit social media links.

Save
Preview to review changes
Publish and verify in a browser

So®

1.5.1 Box CTA — Social
More info:
e Content Authors can convert the Box CTA page component to a Social Box CTA by adding

one or more social media links that replace the standard link.
e When Social Links are selected only the Header and the Social Links will display,

STEPS:

Follow steps for creating a Box CTA. Before saving:

1. In Social Links listbox, select the desired Social Link(s) and double-click or click the right
facing chevron in the center divider.

2. Deselect a Social Link by selecting the item in the Selected section and using the left facing
chevron or double clicking on it.
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n & z el

So0al Links
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1.6 Colleges and Majors Table
Description
More info:

e Tab contents can be split into a 2-column format — see page component “Two-column
Container in Tabs”.

A For Admins and Advanced Users:
More info:
e Because the frequency of reuse of the Colleges and Majors Table is very low it cannot be
found on the Components Tray in Experience Editor or the Insert menu in the Content
Editor.
STEPS: To Add the component to a page:

In Content Editor click on the page in the tree. Then choose “Details” on the Presentation tab.

HOME NAVIGATE REVIEW ANALYZE PUBLISH VERSIONS CONFIGURE E SECURITY VIEW MY TOOLBAR

Item 1D: {2E206BBF-ACFF-49AE-G713-B25ZE3ATFBCA}
item name; _NKTest
ltem path: fsitecore/contenuMSUMSUMHome/DeQued/ NK Test
Template: fsitecore/templ stes/ Project/MSU/Pages/Page - (C1805BAA-CADA-4684-023D-F13DAA0S7EE0}
e
Created from:  [unknown)
) faculty-staff Item owner: secore\Admin

v Y Y Y v v ¥y v v v v w

Clickonthe “Shared Layout”tabinthe popup. Scrolldownuntilyou see “Edit” underthe “Default”
section. Click on Edit.
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Layout Details

The details of the assigned layouts, controls and placeholders.

SHARED LAYOUT

Sitecore CMS Components User Guide

El‘«’xastf‘ead

Brand Bar

Ek’:asthead - Mobile
I =

un

un

ite

T
)

Brand Bar - Mobile

Main Navigation

Main Navigation - Mobile
Breadcrumb

Footer Layout

Footer Links

Footer Contacts

Footer Social Media
Footer CTAs

Footer Secondary
Colleges and Majors Table
Side Tabs

Select the “Controls” tab and click on “Add”
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Device Editor

Set the layouts, controls and placeholders for this device.

o MetaTags
e Placeholder: MetaTags

Te
Header Layout

PlacehiolderSettings Placeholder: phHeader

Datasource:
Alert Level 1

Add

Datasource:

Placeholder: Masthead
Datasource: /sitecore/content/ MSU/MSU/MSU
Components/MSU Header/Masthead

Placeholder: AlertBar
Datasource:
Masthead

Masthead - Mobile

Placeholder: Masthead-Mobile

Datasource: /sitecore/content/ MSU/MSU/MSU
Components/MSU Header/Masthead

Brand Bar

Placeholder: E}randBa:f ‘
Datasource: /sitecore/content/MSU/Global
Compenents/Global Header/Brand Bar

I Brand Bar - Mobile I
Placeholder: BrandBar-Mobile

Datasource: /sitecore/content/MSU/Global
Components/Global Header/Brand Bar v

0
[~

i

m

In the new popup navigate to Renderings>Feature>Shared>Components>Colleges and Majors
Table.

Make sureyouenter“‘phMainContent”inthe “AddtoPlaceholder:”field. Checkthe onlycheckboxon the
popup and click “Select”.
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Device Edi Select a Rendering
I Set the layouts, Select the rendering that you want to use. Click Select to continue.
@

Layout Search Renderings... Add
NKTe -
| CObDi 4 gt Renderings —ifjee—
Placeholder 5 (@ Foundation
4 (g Feature <
> (@ MSU

» (@ MSUToday

4 (g Shared
| 4 7] Components e -
B ® Ad-Coming Soon

m Advanced Accordit

>  Alerts Colleges and Majors Table
form @ Box CTA
en: » ] CallToAction

m Colleges and Majo T-—
- ! 3 -

Add to Placeholder: | phMainContent

Open the Properties dialog box immediately. Select Cancel Cancel

n Title: /

In the new popup Browse to select or create a new data source for the component.
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Set the layouts, controls and placeholders for this device.

Control Properties

NK T _ s N
General A

. Placeholder [shared]: -
phMainContent

\Data Source [shared]:
ne:

Clear
hi
B
from: .
ner:
Caching [share
[[] Cacheable

Clear on Index Update

HEVIEW ANAYTE

2L

VEIONS

SECLRTY

ViEw

MY 700 AN
Select the Associated Content

Select the content that you want to associate with the rendering and use as the data source.

D Select an existing content item.

4 [ Paige Components

» 8 Advsnced Accord

b & Sicie Tam Jor=
> & Tsbz Compane
ey b W TeaCThs
[E] Rich Texr

Cancel
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Device Editor

Set the layouts, controls and placeholders for this device.

Control Properties

General

Placeholder [shared]:

phMainContent

Data Source [shared]:

Browse Build query Paste query Clear
/sitecore/content/MSU/MSU/Home/DeQue3/_NK Test/Page Components/Colleges and Majors Table
B

Lt

Caching [shared]

. [C] Cacheable -
Clzar on Index Update \

:sgé “ cance,

Click OK on all the open popups and make your way back to the Content Editor
Inthe Tree, clickonthe componentthatwasjustcreatedandintherightpane modifythe necessary fields.

32 |Page



University Communications, Michigan State University Sitecore CMS Components User Guide

Quick Info

Item ID: {597C0B66-50E6-4F89-A2BE-0118DFO32E3A}

ftem name: Colleges and Majors Table

Item path: /sitecore/content/MSU/MSU/Home/DeQue3/_NK Test/Page Components/Colleges and Majors Table

Template: Isitecore/templates/Feature/Shared/Components/Colleges And Majors - {ASEDO5DA-6DA1-426D-BAB:
.. Created from: [unknown]

Item owner: sitecore\nkarimi

Component Data

Eyebrow:

Tab Cne Title [stand ’/
Nav Colleges

Tab Two Title [standarg

Majors

1.6.1 Colleges Tab
STEPS: To add to the Colleges Tab:

Open the Experience Editor, click on the “Add Component” icon. Select the “Add here” inside the
Colleges tab.
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- HOME  PRESENTATION SESRNEN  VERSONS OPTIMIZATION  VEW
N ¥ Explore
i -
o o || ©16 e 1004w || F,

Colleges
4 Add berz
Majors
All Colleges ~ All Programs - Keyword searct
A B € b E F 6 H I J K L M NOWPQ@QR S T UV WX Y 2z

Showing 1to 50 of 524 entries

Select the desired component from the popup.

Select a Rendering

Select the rendering that you want to use. Click Select to continue.

ks
a] o Single Mixed Content Advanced Accordion
A

ges
Open the Properties dialog box immediately. ﬁ Cancel

E D L Sl el i - st b\ s o G il © dd Sl © ]| ] i U s i D

Modify the Content for the added component as per specific instruction for the component.
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1.7 Contextual Navigation

Description
Usage:

More info:
¢ Contextual Navigation can be added to the right column of a two-column page. It will pull in
other pages within that same folder structure.
e As the visitor scrolls down the page, the contextual navigation always remains in view.
¢ If a site-level component is used for the data source, neither the 66/99 container nor the
Contextual Navigation component appear in the content tree in the page components node.

Example:

g elit. Donec ut mauris

Testing
urna et urna semper, sed
ictum, enim risus gravida o
ISed nec tortor ultricies, Child #1
e enim. Morbi augue orci, Child #2

vel dui sed risus dapibus

itor aliguet hendrerit vel,

h nunc. Phasellus dictum

quet. Suspendisse at nisl

STEPS:

To place the Contextual Navigation component on a lower-level page, CA must first add a Two
Column Container to the page within the Experience Editor.

1. First click the “Add Component” icon.
2. Click “Add Here” (on hover, “MainContent” should show).

3. Select “TwoColumnContainer_66_" from the popup.
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2 2. £26 = o065ewd B

Hero Banner Small Helaht

Select a Rendering

St penclering 1t yoU W ) W DAk SefRcT 15 continy

Introduction Title

4. In the right column click the “Add Here” and select “Contextual Navigation”.

Small Height

Select a Rendering

Select the rendering that you want to use. Click Select to continue.

)
F) ==
er
lig Contextual Navigation Rich Text Social Share
g
di
=
|1 C
ne - x : : fitl
Open the Properties dialog box immediately. Cancel '
li Ith
|9\.HC‘I STUITIIagna Uiciunm portal mNuna gquis 1orernt ut noero =
A B T R R R i A e ISRy ES R S DS PR P By S hh ftect nana titla

5. Select the Associated Content or Create New Content.
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1.7.1 Navigation links
STEPS: If CA intends to add extra navigation links to the Contextual Navigation:

1. In Content Editor select the component in the tree, right click and select
Insert>NavigationLink. Give it a name.

» [ test-michele-publisher-4
Contextual Navigation
4 [ ateamuat

4 [[] Page Components : .
Additional Navigation ltems:

4 =] Contextual Navigation - Hand curated

@ CollfoActionButton Insert » @ CallToActionButton
@) Media 1 @ Search & NavigationLink
[B Media 2 [} Duplicate [ Insert from template
8] Media 3 ® Delete
» [M Photo carousel with captio ™ Rename

E] Rich Tex: Features Copying »

[) Naeim Newsletter subscribe test Sorting »

[ test-michele-event-landing-page 2 Edr

[) test-michele-publisher-5

>

»

»

3 Conscle

» [ Testn

>

>

>

8§ Scripts >

& Refresh

[ about

[) academics 1] Is Background Dark

[) accessibility

2. Inthe right pane add Text to be displayed, the Link, and icon if needed.

r wutio

» [ tdb-IT8-2
Quick Info A |l
& redirecttest

» 2t PD Page Naeim Test
» [ testmichele-events Item ID: {11DFC82E-653D-4552-0746-EADSD6D783CA}
» [ testmichele-training-1 Item name: NavigationLink
» [ test-mc-publisher
Item path: Isitecore/content/MSU/MSU/Home/a-team uat/Page Components/Contextual Navigation - H |
» [ testtdb-publisher
» i:] test-michele-publisher-4 Template: /sitecore/templates/Feature/Shared/Components/Datasource/NavigationLink - {932E999B-0!|
4[] aeamuat Created from: [unknown]
4 [l Page Components
Item owner: sitecore\Aelsabagh

4 [z Contextual Navigation - Hand curated

v |
% ColiToActionButton
o 2 t Content A

& NovigationLink [

> Demo Advanced Accordion NavigationText:
“ﬁ} Media 1
5 First navlink
[H) Media 2
B Media 3

NavigationLink:
» 4 Mixed Content 1 Col L

t media link rt external link Insert anchor

» [ Photo carousel with captions

Follow
» & Tabs Component
/MSU/MSU/Home
[E] Rich Text Features
» [) Naeim Newsletter subscribe test o
Navigationlcon:
» [® test-michele-event-ianding-page
Information v

» [ test-michele-publisher-5
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1.7.1.1 Navigation Icon

Note: This section is for advanced/admin users

STEPS: To configure the icons that appear in the Navigation icon in the dropdown list follow these
steps:

1. Navigate to this URL to find the desired icon: https:/fontawesome.com/icons?d=gallery
2. Copy the icon’s class “fas fa-address-card”

address-card
Solid Style (ra - BB + fb - iz~ faz fa-address-card

Users & People + U I Version 503

3. Navigate to this item within sitecore /sitecore/content/MSU/Global
Configurations/lcons/Navigation Icons

4. Insert a “Single-Line Text Config” from the Insert menu
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» @ Dictionary (@ ConfigFolder

» ) Global Components &3 Single-Line Text Config
4 @& Global Configurations @& Single-Line Text Config Shared
» @ Ad - Coming Soon Config & Chedkion ot
b ) AlertLevels

(] Colleges

@t Checkbox Config Shared

&3 Multi-Line Text Config
{@ Contacts
&g Muld-Line Text Config Shared

&3 Image Config

4
4
» @ Grid Configurations
» @ Hero Text Size

4

&g Image Config Shared

{@ Highlight Styles b
4 @ Icons &3 DropTree Config
4 Navigation ===~ @t DropTree Config Shared
Insert 4
&3 address & Treelist Config
Q  Search :
&3 Informa g Treelist Config Shared
li
» @ Social Medi [ ‘Dupsicats &3 General Link Config
- Al let
P {d Image Alignmi % Dele= @& General Link Config Shared
b (J ImageFacss1 = Rename &3 Rich Text Config
» (@ Image Orientz CoPYing  » &% Rich Text Config Shared
@ Image Siz i
b @ Image Size SoHng ' &3 DateTime Config
» @ Masthead Coli » i
@ # Edi gg¢ DateTime Config Shared
» @ Mixed Conten "
" Console &3 Date Config
> @ News Topics o 724
b @ People Heade B Scriprs t &g Date Config Shared
@, < < <
J €9 Refresh & CodeBlock
» i Side Tab Types g
»_d& Social Media Platform 8 GodeBlock Shared

il Media Library Workbox [ Insert from template

5. Paste the class you copied in the “Value” field and enter the name of the icon in the “Key”
field
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Q::} address card

Quick Info

I

Item ID: {4808319A-E2(7-44D9-AAF2-DOFBEDEAF545}

Item name: address card

Item path:  /sitecore/content/MSU/Global Configurations/icons/Navigation Icons/adc
Template:  /sitecore/tempiates/Foundation/Shared/Configuration/Types/Single-Line
Created from:[unknown]

Item owner: sitecore\Admin

I

Configuration

Value:

fas fa-address-card

Base Configuration

I

Key fshared]:

Information

1.7.2 CTA Button
STEPS: If CA intends to add a CTA button to the Contextual Navigation:

In Content Editor select the component in the tree, right click and select Insert>CallToActionButton.
Give it a name.
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» [ tesr-michele-publisher-4
. Contextual Navigation
4 [ ateamuat

4 [l Page Components L A
Additional Navigation ltems:

4 |tz Contextual Navigation - Hand curated

@ CollToActionBurton Insert » 4 CallToActionButton
) Media 1 Q. Search & NavigationLink
8] Media 2 [ Duplicate [ Insert from template
[H) Media 3 ® Delete
» [M Photo carousel with captio = Rename
[E] Rich Text Features Copying »
» D Naeim Newsletter subscribe test Sorting b
» [* test-michele-event-landing-page / Edit
» ? test-michele-publisher-5 s
Pl T 8y Scripts >
» [ about
& Refresh

» [ academics I s Background Dark

In the right pane add Text to be displayed and the Link.

B -

Created from: [unknown]

Item owner: sitecore\Admin

insert link nsert media fink Insert external link Insert anchor Insert emai nsert Clear

All Selected

>

Once the link has been added it will appear in the tree under the Contextual Navigation component
as well as in the “Additional Navigation Items” allowing it to be selected and displayed.
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Additions| Navigstion ftems:

Make sure to Save and Publish the changes.

1.7.3 Hand curated Contextual Navigation

More info:
e Content authors have the ability to manually modify the title of the contextual nav.
e Content authors also define links and CTAs that appear within the component.

STEPS:

1. Select the Contextual Navigation item from the content tree to view its fields in the right
pane

2. Inthe “Additional Navigation Items” field you can choose to display the CTA/Navlinks that
were created in the previous steps

3. The Contextual nav automatically takes the title of the page it falls under. However, that title

can be modified by checking the Is Curated checkbox and then populating the Navigation
title field with the desired title
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[ test-michele-events

[ test-michele-training-1 R et o~

»

»

» [ test-mc-publisher
Y Additional Navigation ltems:

» [ test-tdb-publisher

»

w1

Deselect all

[ test-michele-publisher-4 -

All Selected
4 [ a-team uat

CallToActionButton

4 [l Page Components NavigationLink < b4

4 |tz| Conzextual Navigation - Hand curated
;\.’é, ColiToActionButton
& NovigationLink
[B) Media 1
@ Media 2
[H] Media 3
» Photo carousel with captions
] Rich Tex: Features
[ Naeim Newsletter subscribe test (] 1= Background Dark
[* test-michele-eventianding-page
[} test-michele-publisher-5

D Test-jn Curated Navigation A

[ about
0 o Is Curated
academics

[ accessibility
Navigation Title:
@ MSU News

[ News Test Page Hand curated title

v v v v v v Vv v v Vv

[® Test Event Landing
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1.8 Event Listing

Description
This component will be deprecated. Instead, use the new Events feature.
Usage:

More info:
o The event listing component can be added to any page to showcase relevant events.

Example:

STEPS: The component can be added by following these steps:

1. Right click on the Page components folder of the respective page
2. Click on Insert to expand the Insert menu
3. Select Event listing from the Insert menu

% PD Page Naeim Test Itam IN- o0

<

AG - Coming Saor
» [ testmichele Ad-Coming Soon

N test-michele [ Advanced Accordion
» test-mc-publisher & Advanced Mixed Content 0
b [ Carousel 5
» @ Eventlisting
i
» =3 Hero Banner
» =2 Hero Banner - Story ’
N Hignlight I
4 [ Tes [®] 1mageFacts
4 (@l par~ rnmmnannnes Introduction
22 nsert »
» [0 €] LinkslList
Search it
» ] about # Media
"] Duplicate
» acade B Medis Contact
3 ® Delete {
» | ] acces ®  News Listing
» B NMSU Rename et .
! MSU e Newsletter Subscribe
N i Copying »
» New Pying & Quote fc
* o Sorting » =
» [ TestE s Rich Text #
g 7
\ Test J Eait _— - ¢
b L] Test) M Side Tabs Component )
. [T] Console ¢
| Test-i Cimal " Iy o -
b L] Test § Single Mixed Content With Social Media 4
» M alumt B Scripts » _
] slum: B M Tabs Component s
» calen @@ Refresh - :
s 4 » TexxCTAs

Media Library = Workbox Insert from tempiate

1.8.1 Configure the Event Listing component
STEPS: Now configure the Event listing component:
1. Enter the Heading that you want to appear at the top of the Event listing component

2. Define the CTA label and link if you want to have a CTA at the bottom of the Event listing
component
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3. Select the desired events

Event Listing Details ~

Heading:

CTA Label:

September 4 - Campus Event
September 8 - Campus E
aug 10_spending plan
aug 11_diabetes

aug 12_summer fun

aug 14_diabetes

aug 15_diabetes

aug 16_diabetes

aug 17_family meditation
aug 18_safe food

aug 19_informed renter

i e

1.8.2 Create Events
STEPS: First create the events that appear in the “Event selection” field:

Navigate to the Events folder /sitecore/content/MSU/MSU/MSU Components/MSU Events
Right click on the MSU Events folder

Select Insert to display the Insert menu

Click on Event

PN~

4 {J MSU Components “

» ) MSU Call to Aczion
!
4 UM Insert » [M Event i
- Search @ Eventlisting n
» ]
; 51 Duplicate [# EventTile Auto Cycle
b
4 ® Delete .| Events Folder
2 . w
Rename ) Insert from template
™
Copying » Cre:
> g
Sorting » Iten
2 fvocate
J Edit
) -
M nsol
s Co e
- B Scripts »
®% Refresh .
A.,.f] S o.( L

row
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1.8.2.1 Configure the Event
STEPS: Populate the Event fields to define what appears in the Event listing component:

Select an image to appear in the Image field

Input details such as event Title, Start/End Date

You can use the Show Start Date only checkbox to only display the start date

Insert a link that you want this Event item to link to if selected from the Event listing
component

Use the Event display data fields to define when you want this event to be listed on the
website

Image:

PN~

o

[ Is Background Dark

Title:

Test event

Start Date:

10/19/2020 -

9/2020

End Date:

Today Clear

10/19/2020 =

[J Show Start Date Only

Event Display Data ~

Put Up On Site:

Take Down:
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1.9 Event Tile Auto Cycle

Description
Usage:

More info:
o Event Tile Auto Cycle will display an event from a list of events automatically based on the
“Put Up” and “Take Down” Date and Time as defined by the Content Authors.
¢ Content Authors must make sure that they don’t create a “race” scenario where two events’
uptime overlaps.
e This component can be used in the Grid. The data for the Events can be housed both at the
node level or the global level.

Example:

STEPS: To add or modify the content (data) for the component:

1. In Content Editor navigate to the right folder:
a. For MSU: /sitecore/content/MSU/MSU/MSU Components/MSU Events
b. For Global: /sitecore/content/MSU/Global Components/Global Events

2. Select the Events folder and right click. Select Insert>Event Tile Auto Cycle. Give it a name.
» | Global Contacts
Global Evant Start Date:
nsart » @ Eventusting
“ »
Search # Event Tile Auto Cycle
e Duplicate /® Event Tile Constant
. ”® D=lste w2t from template
- ename o
> "
Y apying »
R | Sortir »
ot
Y K efrest « Show Start Date Or
» i
» ¥ t t
3.

4. Give ita name.
5.  Select the Event and in the right pane set the “Put Up On Site” and “Take Down” fields.
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Mage:

6. Click on the Event and in the right pane add the image.
7.  If the background image is dark check the “Is Background Dark” checkbox.
8 Enter the Title and the Start and End Dates. If you don’t select “Show Start Date Only” the
date will be displayed as a date range.
9. Addalink.
10.  Save and Publish the changes.
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1.10 Event Tile Constant

Display one event

Usage:

More info:

Event Tile Constant is manually curated by the Content Authors.
Data for the Events can be housed at the node level and in the site’s global components.

Example:

STEPS: To add or modify the content (data) for the component:

1.

2.

ok w

In Content Editor navigate to the right folder:
a. For MSU: /sitecore/content/MSU/MSU/MSU Components/MSU Events
b. For Global: /sitecore/content/MSU/Global Components/Global Events
Select the Events folder and right click. Select Insert>Event Tile Constant. Give it a name.

Ine current iem
» ) Global Contacts

[ W
Insert » g Eventlisting

» & Event|
Search [ Event Tile Auto Cycle
» P Event” 2 b
[ Duplicate /> EventTile Constant 1
A Event’
i Delete L Insert from template  3joba
» . Global Fo
=1 Rename
» {_ Global He Item path: [sitecc
. Copying »
» & Global Pl Sorting ; Template: Jsitecc
» & Global Confi
J Edit Created from: [unkn
- Forms
& Refresh :
™ Layout Item owner: sitec

Z Madiaiikran:

Click on the Event Tile Constant and in the right pane add the image.

If the background image is dark check the “Is Background Dark” checkbox.

Enter the Title and the Start and End Dates. If you don’t select “Show Start Date Only” the date
will be displayed as a daterange.

Enter the link.

Save and Publish the changes.
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Is Background Dark

Tie:

title

Sitecore CMS Components User Guide
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1.11 Grid Container

A container for 1 to 6 page components, displayed in table fashion (no borders or spacing
between cells). A Grid property controls the number and layout of the cells (tiles).

Usage:
¢ Tiled content (especially on Home page)

More info:

e Grid is a container and hence needs to be added from the Experience Editor. The Grid will
not appear in Content Editor’s list of page components.

e In EE, adding a Grid is the same as adding any other component. When creating the Grid,
a popup asks you to choose the layout. Once a Grid is added, an “Add here” label is
displayed in each of the Grid cells so that you can select the page components to place in
each cell.

¢ Only certain page components can be used in a Grid. When you click a tile to “Add here”,
all grid-ready page components are shown: Ad-Coming Soon, Box CTA, Event Tile Auto
Cycle, Event Tile Constant, Media, Rich Text, Social Feed, Story, Text Fact. Additional
components may be added later.

Example 1: Tiles (page components): Media (graphic image) and Ad-Coming Soon
Source: MSU Home page https://msu.edu/

1110 oneer

University

Academic programs

TS

.

WE'RE . COMMITTED TO DOING
MORE. ™

Learn how

MSU programs ranked in the top 25 nationally
N

Example 2: Tiles (page components) — Story, Event Tile Auto Cycle
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Sep. 23, 2020

Tips to Build and Protect your Credit

CESAR CHAVEZ'S LEGACY AT MSU

Example 3: Tiles (page components): Ad-Coming Soon
Source: Test page

CTA BOX HEADER L) CTA BOX HEADER L2

Top Header

Sub Header L1 Sub Top Sub header Line 1 Top
Header L2 ° Sub header Line 2

BOTTOM HEADER

Bottom Sub Header Line 1 Bottom Sub Header Line 2

Image Caption 2

STEPS:
The Grid component must first be added in EE.
In Content Editor:

¢ In the content tree, navigate to the page and click it.
e Goto EE: Publish ribbon > Experience Editor

In Experience Editor:

1. Click Add a new component icon (upper right)
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6.

[ [ [ ] : :
HEE Experience Editor

mm|
ﬂm HOME PRESENTATION

2. Click “+ Add here” to indicator where Grid will be placed on the page

3. Select “Grid Container” and SELECT — wait for EE to create the component
4. Select a Column Layout (illustrated below) from dropdown list and click OK.
(Grid Layout samples are below, after Steps)

Control Properties O X

_.lE

Column Layout:

3 Sma v
]|
XlLarge
2 Medium
3 Small
3 Tall
1 Tall 4 Small
4 Small 1 Tall
1 Large 2 Small
2 Small 1 Large
1 Large 1 Ta

Tal 40 S
I Tall 1 Large

6 Small

Page components can be added to the Grid now or later. To add a component to a Grid

cell in EE:

a. Click a Grid cell

b. Click “+ Add here”

c. Select a component from the list — available Grid components to use in a Grid are: Ad
Coming Soon, Box CTA, Event Tile Auto Cycle, Event Tile Constant, Media, Rich Text,
Social Feed, Story, and Text Fact.

d. Click Select

e. Click “Create New Content” unless the component was created in Content Editor.

f. Click OK — wait for Sitecore to add the component to the cell.

g. Continue until a data source is selected for all cells.

SAVE and close EE tab

In Content Editor — after the Grid has been assigned page components (data sources):

Note: The Grid component does not display in the content tree.

7. Enter content into each new component added to the Grid and SAVE.
8. Optional: Preview the page and review changes made — Publish ribbon > Preview
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9. Publish the entire Page Components folder.
10. Verify changes in a browser.

GRID CONTENT LAYOUTS:

XLarge

Medium

3 Small (one row)

3 Tall

Sitecore CMS Components User Guide
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1 Tall 4 Small

4 Small 1 Tall

1 Large 2 Small
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2 Small 1 Large

1 Large 1 Tall

1 Tall 1 Large
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6 Small
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1.12 Hero Banner

A large banner image or video (full page width), placed prominently at the top of the page,
that serves as the background for the masthead. Text is used as the page title.

Usage:
e Home page
¢ Index page of each main section of the website (i.e. main navigation items)

More info:

¢ Field: Use Gradient — always check this box for adequate color contrast

e Field: Hero Banner Size — Regular and Small; Home page is usually Regular

e Field: Hero Text Size — Large, Medium, Small

e |f a page does not have a hero banner, the page title must be added manually using
another page component like Rich Text or Highlight.

e See page component “Tabular Directory Filters” to add a hero banner with dropdown
selectable filters.

Sub-component: CallToActionButton

Example 1: Source: MSU About page https://msu.edu/about

For: Students | Alumni | Faculty & Staff Apply | Visit | Give

(R mewoan srare s

g (et
i g

About | Admissions | Academics | Research | CampusLife | Athletics MSUToday

e, Y

2 —— :;._,__—s:’_‘f'

About MSU

Example 2: Hero Banner with CTA button
Source: MSU Home page https://msu.edu/
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About | Admissions Academics | Research Campus Life | Athletics

y YN )
be our highest priority. We're working hard
to support an engaged experience for all
Spartans, wherever they are, and moving
forward together.

Learn more

Example 3: Hero Banner with Tabular Directory filters

ﬁ MICHIGAN STATE UNIVERSITY For: Students | Alumni | Faculty & Staff Apply | Visit | Give

Online Programs | Resources Online Students | How to Apply

Bl 0 756

World-Class Eﬂucation
”) - X \»\_

Explore your online*and"hybrid program opportunities

Degree Type 34 Field of Study .

STEPS: To add or modify the content (data) for the component:

1. In Content Editor, navigate to the component under the Page Components folder of your
page. Select (click) it in the content tree.

In right pane, modify fields in Hero Banner section:
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2. The Hero Banner may have a background video. You can select the video from the right
column by either double clicking or clicking on the right facing chevron. You must add
images to your banner even if you choose to have a background video.

contere Y

3. Add the Desktop Background image. Click Browse and select an image from the Media
Library. To add Alt Text: click Properties and enter text.

Add Mobile Background image if different from Desktop image.

Enter Banner Title — displays in very large text (required)

Enter Banner Description — displays below Banner Title in large text (optional)

B

o oA

7. Add a CTA button (optional) — refer to the section below for instructions

Note: If Banner Description is specified, button displays on a new line, otherwise button
displays on same line as Banner Title.

10.2 After adding the CTA sub-component, select CallToActionButton from dropdown
(must also create the CTA sub-component — instructions below)

10.3 To remove CTA button without deleting CTA sub-component, select “None” in
dropdown.

8. Modify the Hero style with these options — Center Align Text, Use Dark Text, Use Gradient
(should ALWAYS be checked).

9. Select Hero Text Size — use MSU — Regular for standard content pages
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| -

CTA Button

Center Align Text
Use Dark Text

¥ Use Gradient

Hera Banner Size /
M3U - Smai

«# Add Horizontal Line

Hero Teyt Size /

10. SAVE.

NEW component ONLY — In Experience Editor:
11. Add Hero Banner component above Breadcrumbs component.
12. Select the data source (the component created in Content Editor).
13. SAVE and close EE tab

In Content Editor:

14. PUBLISH

1.12.1 Create/Select a CTA

More info:
e A CTA (Call to Action) sub-component can be either local or global.
¢ |If alocal CTA exists, the Hero component’s CTA field dropdown list will ONLY display the
local CTAs available for selection.

STEPS:
Click “None” to remove the CTA button from the Hero page component without deleting the CTA
sub-component.
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CTA: @ [none]
v ctat
ctal v

If no local CTAs exist, clicking the Hero CTA field’s dropdown displays the Tree and a CTA button
destination can be selected.

Deleting local CTAs displays the Tree and allows selection.

CTA: @ [none]
4[] sitecore
4 & Content
#, Home
Gradient : » ¥ Global Configurations
> @ MsU
Blaek »  Forms
» [F Layout
Text Alignment : » & Media Library
b &y System
Center Align » [ Templates

To create a local CTA sub-component:

g. Right click the Hero component in the tree. Select Insert > CallToActionButton and give it a
unique name (does not display on page).

Bl DQ Media Video

4 J M
4 i) Hero Banner LJ MSU
- Insert » .4 CallToActionButton
@ olroa
4 MSU Component: Search | Insert from template

[ MSU Compo ¢
» ¢ MsuUCalltoaq D Duplicate

MSLJ Fvents ®  Delete

h. In Text field, enter button text — this is the button label, i.e. text that displays on the button

i. InLink field, indicate button destination, can be Internal or External.
If selecting an Internal page to link to, the page must have its “Include in Navigation”
checkbox selected.
a. Insert Link — (internal link) select page or other asset, enter Description (tooltip),
Target (“Active Browser” or “New Browser”), Alt Text. Click INSERT.
b. Insert Media Link — select file from Media Library, enter Description (tooltip), Target,
Alt Text. Click INSERT. (Can upload a file during component editing)
c. Insert External Link — enter Link Description, URL (fully-specified), Target, Alt Text.
Click INSERT.
d. Insert Anchor
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Text:

READ MORE

Link:

Insert link Insert media link Insert external link Insert anchor In

/MSU/MSU/Home/academics

j-  Enter Campaign information (optional)
k. SAVE - sub-component name will now display in CTA field of Hero page component
[. In the Hero Banner page component, select a CTA from the dropdown — this is the active
CTA that will display on the page.
To create a global CTA sub-component:
4. Remove any local CTAs if they exist.

5. Click CTA dropdown and select a destination in the Tree
6. Save
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1.13 Highlight

Description
Usage:
More info:
¢ Highlight is a global component. There are five different variants of the highlight. Only Mono

Black uses both Quote Line 1 and Quote Line 2 fields and the rest only use Quote Line 1.

Example:

Lorem ipsum dolar.

Stet clita kasd gubergren, no sea
takimata sanctus est Lorem ipsum
dolor sit amet.

STEPS: To add or modify the content (data) for the component:

1. In Content Editor navigate to Page Components folder of your page and right click. Select
Insert>Highlight
2. Give it aname

»
4
[J] Page Componant= i Ad - Caming Sonn [ Advanced Accor
Insert » (¥ Ad-ComingScon
0 Search Advanced Accordion
[P Duplicate @@ Hero Banner Mixed Content
8 Delete = Hsfo Banner - Story
» = Rename ) Highlight
! Copying Te oty
» Sorting » [B Introduction
’ ¢ Edit €1 Links List
} 3] Console Eﬂ Media
b 8§ Scripts » A Media Contact
> emergency
0 Beny & Refresh & Mixed Content
» [ engagement College
E E8 Newsletter Subscribe
» [7] RDA-grids
- [M Photo-Caption Carousel
» [ issues-statements
a Juote
» [ Page R Quote
¥ ) privac E| Rich Text
» a research & Side Tabs Component
- TR i i

3. Click on the component and in the right pane fill in the appropriate fields
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Highlight

Quote Line 1:

Donec rutrum congue leo eget malesuada.

Quote Line 2;

Mauris blandit aliquet elit, eget tincidunt nibh pulvinar a.

Style: /

Mono Black

4. Save and Publish yourchanges
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1.14 Image Facts
Description

Usage:

More info:

¢ This component allows you to place facts from Global Facts on top of an image
background.

Example:

STEPS: To add or modify the content (data) for the component:

1. In Content Editor navigate to Page Components folder of your page and right click. Select
Insert>Highlight
2. Give it a name
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¥ || EXperLusung
b [ rwrest
» [ SCtest
4 [ NKTest
» [) DFtest
4 [[I] Page Components
14 Advanced
é Colleges a
[zz] Contextuz
b i) HeroBart ¥
@ Highlight
@ Image Fac
{# Media Cor
» & Side Tabs
> & TabsCom
P I TextCTAs
E] Rich Text
[E] Rich Texti.. -
E] Title - Lede
» [ bb_test

» [ faculty-staff

Media Library Workbox

3. Choose a background Image

Background Image - Desicop:

wse Proo=rties Open me=dia library d =ge

(AssetsIMEUmagesifa

-medistfor_media_bero

Background Image - Tabler:

‘owse roparties Open madia fibrary Editimage

Insert
Search
Duplicate
Delete
Rename
Copying
Sorting
Edit
Console
Scripts

Refresh

Relr=sh

Sitecore CMS Components User Guide

Ad - Coming Socn

®

Advanced Accordion

G

Hero Banner

Hero Banner - Story

High!i&ht

Image Facts

Introduction

Links List

Media

Media Contact

Mixed Content
Newsletter Subscribe
Photo-Caption Carcusel
Quote

Rich Text

Side Tabs Component
Tabs Component

Text CTAs

Yo ame o ap e BERE A

I

Insert from template

4, Select the facts you'd like to use from Global Facts
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Facts;
Seleccall Deselectall

All Selecred

S billion economic impact in ML Institutes and Centers v

Educotion abroad programs

Faa4

Faa5

Fact6

Fact7

Fax8

Faq @

Faculey Inventions

Faculoy and smatf internanonal research

200 Academic programs =t > Alumni worldwide
<
MSU programsin top 25

5.  Choose the background color for the facts

PR —
Academic Staff
Toral Research Expenditures i X

Seyle [sancard valuel:

Translucent Black v }

Grear
Translucent Black
White

Appearance

Help
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1.15 Info Panel

Display a custom message at the top of a page (below main navigation and any hero
banner, and above the breadcrumb links)

Usage:

More info:
¢ The Info Panel component can be added to any page.

¢ The Info Panel cannot be added automatically to all pages. The best way to add this
component to all pages is to create the Info Panel in one page, drag the component to the
sitename Components node, and then manually add the component to every page.

e Enter message in the rich text field; use Plain Text if pasting text; can add links, Heading
tags, and other Rich Text Editor styles.

e The message may contain multiple paragraphs — use SHIFT-Enter to start a new
paragraph.
e The blue background color is automatically added. The color cannot be changed.

Example:

© coronavirus updates

Due to the novel coronavirus, MSU has implemented a number of changes to support our prospective students. See admissions-
related updates due to the coronavirus, including the change to test optional for ACT and SAT.

STEPS: The component can be added by following these steps:

In Content Editor:

1. Right click Page Components folder of the page
2.  Select Info Panel from the list
3.  Give the Info Panel item a unique name
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| o ]
¥ Ad-Coming Soon
Advanced Accordion
- & Advanced Mixed Content
Inser: ' [ Carousel
Bearth =3 Hero Banner
[fl Duplicate =@ Hero Banner - Story
® Delete Q)

Highlight
= Rename Image Facts

Copying  » Info Panel

# Edit Links List

Console Media

Scripts 4 Media Contact

(=]
o
Sorting 4 B Introduction
&l
Hl
a
id

e &

Refresh News Listing

[E3 Newsletter Subscribe

& Quote
E] Rich Text

& Side Tabs Component
& Single Mixed Content With Social Media
& Tabs Component

» Text(TAs

[LI lasest:from templace

4. Inthe right pane, enter the information you want to display in the Content rich text box.
As with any Rich Text component:
— Paste text as Plain Text

— Use SHIFT-ENTER to create blank lines
— Can add links, highlight text and apply Heading tags, change font size, etc.

Info Panel A

Content:

Show editor Suggest fix Edit HTML

5.  SAVE
In Experience Editor:

6. Place the Info Panel component on the page, just above breadcrumb links and below the
hero banner.
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7. SAVE and close the EE tab.

In Content Editor:
8. If the Info Panel component was just added, publish the Page Components node to have

the Info Panel display on the page.
9. If the Info Panel component is not new, publish just the Info Panel component.
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1.16 Introduction

Text serving as a page introduction, expanding on the page title and explaining the contents
of the page in more detail. Optional button link.

Usage:
e All pages, usually first component below Hero Banner and Breadcrumbs.

More info:
¢ Introduction format can be 1-column or 2-column
¢ Introduction component is usually placed first on the page, just below Breadcrumb links
e Button text length is limited (see Example below)
¢ Introduction Component can be used globally, i.e can be placed in the site’s local
Components (not page components) and used as a data source in any page

Example 1: 1-column (paragraph 1 is bolded manually)
Source: MSU About page https://msu.edu/about

Michigan State University has been advancing the common good with
uncommon will for more than 160 years.

A top global university, MSU pushes the boundaries of discovery to make a better world
while providing students with life-changing opportunities.

Example 2: 2-column with Button and Horizontal Line

Intro Title

Lorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna
aliqua.Ut enim ad minim veniam, quis
nostrud exercitation ullamco laboris nisi ut
aliquip ex ea commodo consequat.

Lorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna
aliqua.Ut enim ad minim veniam, quis
nostrud exercitation ullamco laboris nisi ut
aliquip ex ea commodo consequat.

More about MSU Ac...

Lorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna
aligua.Ut enim ad minim veniam, quis
nostrud exercitation ullamco laboris nisi ut
aliquip ex ea commodo consequat.

72 |Page


https://msu.edu/about

University Communications, Michigan State University Sitecore CMS Components User Guide

STEPS: To add or modify the content (data) for the component:

15. In ContentEditor Tree, navigate to page’s Page Components folder:

15.4 To ADD new component: right-click Page Components folder, select Insert >
Introduction, and give it a unique name

15.5 To EDIT existing component: click Page Components folder to expand, and select
Introduction component

Introduction A

Title:

[C] Make Title H1

Column 1 Description:

ow editor Suggest fix Edit HTM

Column 2 Description:

Show editor Suggest fix Edit HTML

CTA:

nsert link Insert media link Insert external link Insert anchor Insert emai Insert JavaScript Follow Clear

In right pane, modify fields in the Introduction section:
16. Title — optional heading about Intro text

17. Make Title H1 — check this box if the page does not already have a component that
creates an <h1> tag (e.g. Hero Banner)

18. Column 1 Description — any rich-text content, i.e. any content that can be created in a
rich-text WYSIWYG (“What you see is what you get”) container

19. Column 2 Description — any rich-text content, i.e. any content that can be created in a

rich-text WYSIWYG (“What you see is what you get”) container.
LEAVE BLANK in order to use the single-column format.
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20. CTA — the button link:

20.4 Select link type

20.5 For Internal link, select a page from the Tree

20.6 For External link, enter fully specified path

20.7 Description — button label, i.e. text that appears on the button

20.8 Target — Active Browser (destination displays in same browser tab) or “New Browser” (destination
displays in new browser tab)

20.9 Click Insert

21. SAVE

22. NEW Introduction component only:

22.4 In Experience Editor, add Introduction component
22.5 SAVE and close EE tab

23. In Content Editor, preview the page and verify changes made (optional) — on Publish
ribbon, select Preview

24. Publish the page component.

25. Verify changes in a browser.
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1.17 Links List

Formatted list of links (internal and external) automatically arranged in ascending date
sequence

Usage: display a list of dated links (news, events, articles, etc.) in a consistent manner

More info:
e Other than the component name, no information is entered in the Links List component. All
content is entered in the Link sub-components.
Link destination can be an internal asset (page or file), an external asset.
Links are listed in the order in which they appear in the Content Editor Tree.
Links are separated by horizontal lines
Date and Link title are separated by a small green horizontal line

Sub-component: Link

Example: Source: MSU Issues and Statements page https://msu.edu/issues-statements

Campus novel coronavirus information

Nassar-related information

Sep. 16, 2020

President Stanley: Statement on resuming college football

Sep. 4, 2020

President Stanley: Statement on building name change

Sep. 1, 2020

President Stanley: One-year progress on Title IX federal review

STEPS: To add or modify the content (data) for the component:
1. In Content Editor Tree, navigate to page’s Page Components folder:
a. To ADD new component: right-click Page Components folder, select Insert > Links
List, and give it a unique name
b. To EDIT existing component: click Page Components folder to expand, and select
Links List component
2. SAVE
3. Create one or more Link sub-components — REPEAT for each Link used:

a. Right click Links List component and select Insert > Link
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» ¥ Ad- Coming Soon Tall

@ DQBoxCTA

@ DQ Box CTA Social

e/'] DQ Lin b lem D L -3
. Insert » & Link
[ bQ Me o
i o 1 Search [ ) Insert from template
| ec
G 5 [ Duplicate Item path: /sitecore/con
» ‘i) HeroBa
Delete
{&] MSU Componen ® Template: /sitecore/tem
2 =1 Rename
» ¢ MsucalitoA e b Created from:  [unknown]
¢J MSU Events
Sorting > Item owner: sitecore\Adm
{Z) MSU Footer
5 .
= & Edit
» ) MSU Header
& Refresh

» ¢ MSU Social M e

» {J MSU Social Media Links

In right pane, modify fields in Link section:

Sitecore CMS Components User Guide

b. Date — click Today, or click the date tool to select, or leave blank

m Q

Item pathc fs ontex

Template: Isitecore/templ
Created from: [unknownj
Rem owner: sitecors\Adman

c. Title — text that displays in the List below date

d. Link:

i. Selectlink type

ii. For Internal link, select a page from the Tree

iii. For External link, enter fully specified path

iv. Description — button label, i.e. text that appears on the button

v. Target — Active Browser (destination displays in same browser tab) or “New
Browser” (destination displays in new browser tab)

vi. Click Insert

4. SAVE

5. Drag and drop Links in the Tree so that they are in the correct order for display

6. NEW Links List component only:
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a. In Experience Editor, add Links List component
b. SAVE and close EE tab

7. In Content Editor, preview the page and verify changes made (optional) — on Publish
ribbon, select Preview

8. Publish the page component.

9. Verify changes in a browser.
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1.18 Media (video and image)
Description
Usage:

More info:
e Media componentisusedforbothvideoandimages. Itistobe usedinthe Grid.

Example:

Academic programs

Undergraduate and graduate programs ranked in
the top 25 nationally by U.S. News & World Report

STEPS: To add or modify the content (data) for the component:

1. In Content Editor navigate to the componentunderthe Page Components folder of your page and select
the Media Component in the tree.

2. In the right pane add the image for the various view ports. The Desktop image will be used if other fields
are empty.

o8

»
-9
. @

3. You can add a caption for the image in the Caption field.
4. If the image is dark select the “Is Background Dark” so that the caption would display correctly.
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5.  To use the component for video, just copy the YouTube ID for the video into the appropriate
field. The desktop image must be added because it will be used as the thumbnail for the
video.
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1.19 Media Contact

Description
Usage:
More info:
e Media Contact component has two major elements: Contact and Place. Making entries in the two

data sourcesis explainedfurtherdown.

Example:

STEPS: Assumingthedataisalreadythere,toaddormodify the content (data) for the component:

1. InContentEditor navigate to Page Components folder of your page and right click. Select
Insert>Media Contact

P ] vriest

4 [[]] Page Components

> Adve Insert » & Ad-ComingSoon ]
&) Cont Q,_ Search Advanced Accordion
» i) Herc [l Duplicate =2 Hero Banner .

@ High ¥ Delete Hero Banner - Story

[®] Imas = Rename Highlight Fo-E
a Med Copying » [®] ImageFacts laces
». & Side Sorting » [B Introduction  reoi
b @ Tabz 4 Edit €1 Links List
> M Text i Mtem
3] Consocle
&] Rich
& Scripts » @ Media Contact mn]
E] Rich
Refresh & Mixeo Content a\Adr
E] Title _E)_ =
= E3 Newsletter Subscribe
» [ bb_test 2
Photo-Caption Carousel
» [ faculty-staff L P
» [ calendars & Quote
» [ campus-life El RichText
» [ celebrations & Side Tabs Compoenent
» [ census2020 & Tabs Component
» [ contactus » TextCTAs

Give itaname

In the right pane fill in the Title and Description for the component
Choose the Contact to be included from the Contact dropdown
Choose the Place to be included from the Place dropdown

Select the Link and Description for the CTA

agRrON=
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Vestbulum ac dam sit anel quam vehicula elementum sed s& amed du. Veshibuum ac diam st smet quam vehicula elementum sec sit amet cun Sad porttdor leclus nibk:

6. Save and publish the changes

1.19.1 Contact Data Source

A For Admins and Advanced Users:

More info:
e Contact Data Source is a Global Data Source where information about individuals is stored.
For Stories both the Contacts and Authors are drawn from this data source.

STEPS: To add or modify:

1. In Content Editor navigate to /sitecore/content/MSU/Global Components/Global
Contacts
2. Right click and select Insert>Contact
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-

A . . leir,
i Global Cali to Action Item path: iDRE
4 ] Global Canrarrs Isite
= Insert & Contact
@ A M
= = Q  Search [ Insert from template [unk
& Aart :
& Asr [0 Duplicate Item owner: sitec
& Aann R Delete
e Contact
& Aany ™= Rename
% Abb Copying
@ opying 4 Topic:
~ A
@ Abb Sorting ’
~ AL
@S Abb ’?9 Edlt
& Abd

MM (Cnncnle

3. Give it a name (this is NOT displayed)
4, Select the Contact you have created and in the right pane fill in the appropriate fields

Item owner: sitecore\Admin

Topic

Topic |

Department:

Department 1

First Name:

naeim kanmi@valtach.com
Display Office Phore Number

Email lcon:

5. Save and publish the changes

1.19.2 Place Data Source

A For Admins and Advanced Users:

More info:
¢ Place Data Source is a Global Data Source where information about places is stored.

STEPS: To add ormodify:

1. In Content Editor navigate to /sitecore/content/MSU/Global Components/Global Places

82 |Page



University Communications, Michigan State University

2.

» ] Global Newsletter Subscribe
4 {J Globa! ™=-~-

& e

¥ Pla

& Stz

» & Global C

@ Admissic
Forms

B Layout

(4

Media Library

wk.
=

System

Templates

)
—d

o

=

Insert
Search

Duplicate

Copying
Sorting
Edit

Console

Right click and selectInsert>Place

Template:

Sitecore CMS Components User Guide

-
W

#» Place

Insert from template

Give it a name (this is NOT displayed)
Select the Place you have created and in the right pane fill in the appropriate fields

n

Name:

SPART)

AN STADIUM

Address:

OFFCE TOWER Spartan Way

Map Link:

sert JaveScripe

5.

Save and publish the changes
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1.20 Mixed Content (deprecated)

A combination of image, video, heading and text with a button link.
Content is arranged in 1-3 columns, depending on number of column sub-components.

Usage:
e Home page
e Main section landing page, providing links to other pages in the section

More info:

¢ Image is optional. If a video is specified, an image is required (it is the video thumbnail that
displays before the video starts).

e A YouTube video can be specified, it displays in a lightbox.

¢ The Mixed Content page component has a minimum of 1 column and a maximum of 3
columns.

e The component uses the full width of the page’s content area (not full width of the viewing
screen). Column image size is reduced according to number of sub-components.

e Column sub-components display on the page in the order in which they appear in the Tree.

e This component is similar to the Cascade Framework Promotion row type.

Sub-component: Column

Example 1: 1 Column, image on left, with horizontal line
Source: MSU Academics page https://msu.edu/academics

Majors, Degrees and
Programs

We offer 200 academic programs across 17 degree-
granting colleges, Discover undergraduate, graduate
and pre-professional offerings.

Learn more

Example 2: 2-columns with images, no horizontal line
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MIXED CONTENT EYEBROW

Sitecore CMS Components User Guide

Column 1 Title

Lorem ipsum dolor sit amet, consectetur adipiscing elit,
sed do eiusmod tempor incididunt ut labore et dolore
magna aliqua. Ut enim ad minim veniam, quis nostrud
exercitation ullamco laboris nisi ut aliquip ex ea
commodo consequat.

Read more

Column 2 Title

Ut enim ad minim veniam, quis nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat. Lorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor incididunt ut
labore et dolore magna aliqua.

Example 3: 3 columns with image, with horizontal line

LATEST NEWS

Champion for women in
science named provost

Following a national search, MSU

President Samuel L. Stanley Jr., M.D.,

named Teresa Kaye Woodruff as the
university’'s next provost and
executive vice president for
academic affairs. She is currently
dean of the graduate school and
associate provost for graduate
education at Northwestern.

Student emergency
funding options

As part of the recently passed
federal CARES Act, MSU will be able
to provide about $15 million in
emergency financial aid grants to
students. Grant applications are
now available for students.

Virtual commencement
scheduled for May 16

MSU will hold a virtual
commencement celebration on May
16. The virtual event does not
replace an in-person ceremony, and
members of the class of 2020 will
be invited to participate in a future
in-person commencement.

Example 4: 3 columns, no images, with horizontal line

Source: MSU Students page https://msu.edu/students
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Email Stuinfo Desire2Learn
Log in to your MSU account. Updates, quick links, questions for Everything you need to access MSU
Sparty. It's all here. Distance Learning.

Log in to Email Log in to Stuinfo Visit D2L Website

STEPS: To add or modify the content (data) for the component:

25.  In Content Editor Tree, navigate to page’s Page Components folder:
25.4 To ADD new component: right-click Page Components folder, select Insert > Mixed
Content, and give it a unique name

25.5 To EDIT existing component: click Page Components folder to expand, and select
Mixed Content component
In right pane, modify fields in the Content section:

26. Eyebrow — optional heading about the component

27. Isimage on left — If creating a single column component, check this box to have image
display on left, uncheck to display image to the right of text and button.

28. SAVE

29. To ADD a column (max. 3):

a. Right click Mixed Content component in Tree, select Insert > Column and give the column a

unique name.
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s s B R I

4 & Mixed Content 1 Col L

Column Template: /sitecore/tem|
g MixedCe © "~ °
- Insert » Column N
WITATU LT
- Search [ Insertfromtemplate  Aqmi
» [ Faculty-Staff = .
) Duplicate
- 0
» [ Issues-Stateme o Deléte e
4 {JJ MSU Components
) = Rename
» J MSU call to Ad " Eyebrow:
i Copying »
{J MSU Events ,
- Sorting »
{] MSU Footer ;
&4 Edit
» J MSU Header
5 Refresh (] Is Image On Left
» ¢J MSU Social Meura unrectory v

30.  Add/Edit Column sub-component fields in the right pane — REPEAT for each column used:
a. Title — a heading that displays above the description and button

b. Horizontal line — check to display a small green line between Title and Description

~

# Honzonsal Line
Description
i gErst fix

Col Two Descapten
VIVEMUS SUSCIE tortor eget fels portiitor volutpat Veibuum ac diam sit amet quam vehicula slementum s=d £ am=1 du. Nuka partiiter accar

Vivamus suscipt tortor eget feks portitor volutpat Dobec solicitudin molestie malesuada Pellentesque in ipsum id oro porta dapibus

MSUMSU Home/ DeQue 1

c. Description — text content

d. CTA - the button link:
i. Selectlink type
ii. For Internal link, select a page from the Tree
iii. For External link, enter fully-specified path
iv. Description — button label, i.e. text that appears on the button
v. Target — Active Browser (destination displays in same browser tab) or “New
Browser” (destination displays in new browser tab)
vi. Click Insert

e. Image — click Browse and select an image from Media Library
An image is required if specifying a video — it is the video’s thumbnail.

f.  YouTube Video ID: enter the YouTube ID (e.g. H8TBxPIGIUQ)
This is the code found after “?v="in a YouTube URL.
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31. SAVE
32. Save and Publish yourchanges.

33. NEW Mixed Content component only:

a. In Experience Editor, add Mixed Content component
b. SAVE and close EE tab

34. In Content Editor, preview the page and verify changes made (optional) — on Publish
ribbon, select Preview

35.  Publish the page component.

36.  Verify changes in a browser.
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1.21 News Listing

Description

This component will be deprecated. Instead, use the new News feature.
Usage:

More info:

e The News listing component allows you to show case the latest news and link to content
pages of those news.

e The component allows the user to filter news items in the list and also complete a search
within the list.

Example:

STEPS: To create a news listing component follow these steps:

1. Navigate to the “Page components” folder that corresponds to the respective page
2. Right click and then select insert to expand the “Insert menu”
3. Select the “News Listing” item from withing the Insert menu

Once the News Listing component is added, you can now configure it:
4. You can select the news source from the “News Repository” field
5. Then you can define the number of stories you want to appear per page
6. Filters & Pagination can be displayed by checking the respective “Show” checkboxes
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Ll e e e g e
s ” uick Info
) Noeim Newsierer subscribe et

%t PD Page Naeim Test Ad - Coming Soon

[® test-michele-event-landing-page 2C7C3-FC1D-4022-982B-91

Advanced Accordion
[} test-michele-publisher-5

»

»

»

% Advanced Mixed Content  der
» [ Testin

»

»

»

»

[} about Cerousel core/content/MSU/MSU/Hc
Hero Banner

[ academics core/templates/Feature/Sh

AE@T 0o

@ Hero Banner - Sto
[() accessibility - i
@) Highlight nown}
@ MSU News ~/
4 [ News Test Page (@] Image Faces ore\nkarimi
v = =3
\j Page Cone B Introduction
Insert »
Binwod & Links U L
Q_  Search
4 ™ News| b Media

2 Lin} [ Duplicate Media Contact

# Linj ¥ Delete News Listing

& Lint = Rename

[

Newsletter Subscribe

b < W t i .
» [*) TestEventL Copying » & Quote
» Test JN Page i

0O J g Sorting > E] RichText
» [ Test-jn-2 » >

: S A &2 Side Tabs Component
» [ alumni Coricole
% & Tabs Component

» [ calendars SE

Text CTAs

v
¥

e & H

Refresh "
[ Insert from template

Creates frem

com coner

Show Flrees

Show Pagreron

Template: Jsitecore/templates/Feature/Shared/Components/News Listing - {B2213F4A-A714-4409-A6DA-ECBE455FC846}
» [ about
» [0 academics Created from: [unknown]
» [ accessibility Item owner: sitecore\dallegrone
» @ MSU News

N

(3 NewsTest Page

4 [ Page Components
) Introduction H1 Test heweRepostory; /

4 ™ News Listing ‘ MSU News /
& Link2
& Link

= Link3

5

» [®) Test Event Landing

» [ TestJNPage Show Filters

» [ Testjn2

» [ alumni Show Pagination
» [ calendars
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You can add external news sources to the News listing component by following these steps:
1. Right-click on the News listing component
2. Select Insert to expand the “Insert menu”
3. Select “Link”, each link corresponds to an external news item
4. Populate the following fields:

e Date
e Title
e Link

Note: If Date field is left empty it will not be displayed and the news items will bubble to the top of
the listing.

’ u academics wreawea iromn LUTIRnOwwIg
» [ accessibility Item owner: sitecore\dallegrone
» [ MSU News

4 [3 News Test Page
4[] Page CompoMagis
B Introducti Insert g Link
4 ® Newslist Q Search [ Insert from template

& Link2 [§ Duplicate

5 Link ¢ Delete Number of Stories Per Page:
& Link3  — Rename 5

» [® Test EventLand Copying i

b: [ TestIN Page Sorting » Show Filters

» E] Test-jn-2 2 Edi

: (3 alumn ] Console Show Pagination

[ calendars

By Scripts | -

Refresh

Item owner: sitecoreVdallegrona
Daze:
ear
26 .

Tide:

emys Jes
Link
mer medis anch - i

tpigoogic.com
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1.22 Newsletter Signup
Description

MSU.edu and MSUToday use only.
Usage:

More info:
e To add Newsletter Signup to a page, CA must first add a Signup Grid.

Example:

Stay connected
=2 Connect With Us

Subscribe to MSUDaily and MSUToday Waeekly to receive timely naws,
groundbreaking research, inspiring videos, Spartan profiles and more

00000

STEPS: In Experience Editor navigate to the page you wish to add the Newsletter Signup to.

92 |Page



University Communications, Michigan State University Sitecore CMS Components User Guide

|| ] . "
HEN Experience Editor
mm

PRESF'«TATION EXPERIENCE VERSIONS OPTIMIZATION VIEW

\ Errors Biochemistry and
Molecular Biology

[J Page Components

College of Oste
Medicine

| about

s Biochemistry and

- -~ Molecular Biology
__| accessibility

College of Natu

| alumni
| DeQue 1
| DeQue 2
| DeQue3
_ faculty-staff
_| calendars
Please enter ' - : ‘e so | can steal your identify
_| campus-life
_| celebrations

Telephone _| census2020

‘H - -

(555) 555-5 L contacius

z | emergency v
Email = yeney

Click on Add Component

PRESENTATION EXPERIENCE VERSIONS OPTIMZATION

sz T Rename - 3 My frems

[l Display nome  Lock <& Workbax Pu

= Lollege or natural Science
| Molecular Biology ‘ —

Click on the “Add here” for the MainContent

kS = L2 [ %]

Setongs Markup Validation Close

Undergraguate
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ERE cxperience Editor
[ £
H PRESENTATION EXPERIENCE VERSIONS OPTIMIZATION
s " ¥ Explore 3 xo = [21 My ¥ P
[# [« o5 _ [ x 1 B (%]
Edz  Previe # Debug Component ncertpage  [§ Movepsge ] Dizplayname Lok <§ Warkdbox Publizh  Semingz Markup  Validation Cloze
> Home > DeQued > n &

LOjiege oF Natural Science unaergraquatce
‘ Molecular Biology ‘

ik Adanere ¥ your information here so | can steal your identify

Adkd 2 new rendering to the 'MainCantant placehzider.

Telepkone

Birthday

05/01/2020

Citbnmit

Select Signup Grid

Select a Rendering

Select the rendering that you want to use. (lick Select to continue.

BN
Image Facts Links List Media Contact Mixed Content
[
; ()
Photo-Caption Carouse Rich Text Side Tabs Signup Grid
v

k| Open the Properties dialog box immediately. Cancel .|

Select the Signup Grid, then click on Add Componenticon again, for the Newsletter Signup click on
NewsletterSubscribe “Add here”. To make sure you are clicking onthe correct “Add here” hover over the button
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and hold for the tooltip which should display as per the image below.

PRESENTATION EXPERIENCE VERSIONS OPTIMIZATION VIEW

Edit  Preview X g Component Inser: pege ¥ Moy Displey neme  Lock < V x Jublizh  Sewings Meckup  Valicatior Cos=

X Loliege or Natural Science unaergraauate
Molecular Biology. ’

# Ada here # Add here

' | Add 2 new rendering to the NewsletterSubscnbe placeholder

# Add here r your information here so | can steal your identify

Telephone

555) 555-5555
(55 -

Click on Newsletter Subscribe

Select a Rendering

Select the rendering that you want to use. Click Select to continue.

rour idi

Open the Properties dialog box immediately. ﬁ Cancel T

Click Select and then link to Newsletter Subscribe under Global Newsletter Subscribe folder.
Click Select.
Make sure to Save. Publish as needed.
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Select the Associated Content

§  Select the content that you want 1o assodate with the rendering and use as the data source.

Cancel
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1.23 Newsletter Signup Configuration
Description
Usage:
More info:
e Configuration...
e Also called Newsletter Subscribe in Page Components dropdown list (Insert)

A For Admins: TBD

STEPS:
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1.24 People Directory

Serves as a landing page on which the visitor can view a list of the people being featured on
the site

Usage:
More info:

Example:

STEPS: To create a People directory page:

1. Right click the site’s “Home” node and select INSERT > People Directory Page
2. Give it a unique name

I 4
» & Global Configurations A
4 @ MsuU _ .
4 @ MsU People Directo
4 %) Horpe
Insert M [ Page
» A .
" Q  Search * Event Landing Page
QW
» B3 [ Duplicate @ News Repository
: {24A454D¢
» O #® Delet= ¢ Redirect (24A454D¢
» [t & Rename 22 People Directory Page 14 People Dir
S Copying » [ Insertfromtemplate femecarelc
4 [ Sorting »
g, Template: /sitecorefu
4§ 2 Edic
M Console Created from: [unknown]
L2l SOIc
» 0 - : o
By Scripts > Item owner: sitecore\z
| 2
q & Refresh
» [ rersonvrage Titles

» [E] Person Page 3
3. In Titles section, enter Page Title, Navigation Title and Browser Title

4. In People Directory section, define the number of people to display per page of the
Directory landing page (for pagination purposes).
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% [Epeene )
& redirecest
[ People Dirsctory nclude in Nowvigation (=
[ restmichele-evenss
[ testmicheleusining 1 B include in Sitemap [shared. sands
[ t=st-mec-publisher

Irclude in Beeadcrumbs [sare

) testtdb-publisher
] westmichele-publisher4
]

Naeim Newsletter subscribe test

Breadcrumb

A Y Y Y Y VY oy w

3¢ PD Page Noeim Test

ponents ] Hide Breadcrumb

People Directory

Number Of People Per Page:

Meta Description

Meta Keyrords:

5. SAVE the page.

Next: Continue by setting up categories (filters) and people detail pages (profiles).

1.24.1 Categories (For Admins)

More info:

e Dynamic categories (max. 3) display on the People Detail pages during page edit where
Content Editors can assign one or more values for each category.

e Categories display on the page and allow the visitors to filter page content (i.e. people
profiles to display).

¢ If none of a category’s values are selected in any of the People Detail pages, the category
is not displayed on the People Directory page.

¢ Only Sitecore Administrators can modify the site’s categories.

Example:

Search catl Department Instruction Methods

oarch Q - = =

Susan L Avery

John A. Hannah Distinguished Professor and Lifetime Achievement Award Recipient
Visiting Educator

Music Education

Donald | Cooper
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STEPS: To modify Categories that will be used as Directory filters by visitors:

—_—

Navigate to /sitename Configurations/People Categories in the content tree.
2. Click People Categories to expand — you should see Category 1, 2 and 3.

IMPORTANT: Do not delete or rename “Category 1”7, “Category 2” or “Category3” items.
If you do not want to use one of the Categories, simply remove any category values, then
clear the Category’s Title content, SAVE.

3. For each Category to be used, enter a Title.

4 ¥ MSU Configurations Ca[egory 1

4 People Categories

Category 1

* conducting

* music-composition Item ID: {5SA15CAAS-A1DA-4B81-9B47-A06598424FE 1}

% musicology

Item name: Category 1

% music-theory

Item path: /sitecore/content/MSU/MSU/MSU Configurations/People Categories/
* x-other
4 Category 3 Template: /sitecore/templates/Foundation/Shared/Configuration/People/Categ
% classroom
. Created from: [unknown]
% online-course
Item owner: sitecore\admin

* private-lessons

% seminar

% workshop
» (& People Headers Title:
» & Hero Banner Size

» (@ Sewings

4 @ MSUToday
4 %) Home

» 4\ Errors

Category displays during People Detail page edit and to visitors on the Directory landing
page as the title of Category dropdown lists of values used to filter displayed content.

g

cat1 De|

All Categories

Test 1
Test 2

4. To ADD a category value:
a. Click the category, right-click it and select INSERT > Category.
b. Give it a unique name
c. Enter a Value that displays to visitors in a dropdown selection list and SAVE.
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» & MSU Sccial Media Links

4 g MSU Configurations People Categories
4 People Categories
Category 1
4 Categoff — nt item does not contain any fields.
Insert > * Category
cong
Q  Search [ Insert from template

musi

oud [1 Dupiicate

musi % Delete item ID: {54B17DCC-80AF-46D0-A268-8125C821

5. To CHANGE a category value:
a. Select (click) a category to expand it
b. Select a value and modify the Value field, then SAVE.

4 @ MSU Configurations = conducting

4 People Categories

Category 1
Quick Info
4 Category 2 /

* conducting

* music-composition Item ID: {82097C3E-1C11-49BE-BEF0-33487F884£09}
musIcOlogy Item name: conducting
% music-theory
" k Item path: /sitecore/content/MSU/MSU/MSU Configurations/People Categt
x-other
4 Category 3 Template: /sitecore/templates/Foundation/Shared/Configuration/People/(
% class n
CassToo Created from: [unknown]
* online-course
Item owner: sitecore\lemonm

% private-lessons
% seminar

% workshop

» ) People Headers Value:

» @ Hero Banner Size
Conducting
» @ Settings

4 @ MSUToday

4 &) Home

» )\ Errors

1.24.2 People Details Page

The People Detail page consists of contact information fields and rich text components for content
such as Biography, Curriculum Vitae, Area of Expertise, etc.

The contact information fields are entered in Content Editor.
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The rich text components are first added to the page in Experience Editor, then content is added in

Content Editor. For consistency between pages, the title of each rich text section can be selected

from a dropdown list of predefined values stored in the site’s Configuration node:
[sitecore/content/MSU/sitenamelsitename Configurations/People Headers

These predefined headers are created and modified by Sitecore Administrators.

More info:

¢ The People Detail page is added as a child of the People Directory page.

e The People Directory page lists all People Detail page, filtered by what the visitor selected
in the Category dropdown lists.

¢ The specific information displayed for each People Detail page is controlled by the
template; you cannot alter which fields are displayed.

e Use of predefined rich text section headers is not required but is preferred.
Components that can be added in the PersonBody area: Advanced Accordion, Header,
Advanced Mixed Content, Rich Text, Social CTA, and Tabs.

STEPS: To create a People details page with contact information:

1. Inthe content tree, right-click the People Directory node and select INSERT > Person
Page.

Choose a naming convention and be consistent. Example: last-first

» [] Naeim Newsletter subscribe test

[a}
o
n
D

Breadcrumb

%e= PD Page Nasim Tesr

o Inse » %] PersonP
P9 Pape G sert [€] Person Page b
b [3] PP Nae @ Search [ Insert from template
» [3] PPNae [1 Duplicate
People Directo
b [*) tescmiche % Delese
» [ test-mich Rename
L] testmiche = Rename Number Cf People Per Page:
> [] Testin Copying »
M . 5
> L] about Sorting »
» [ academic: 7 Edi
4 lﬁ MSU New
By Scripts »
» [ News Test Meta Description:
@& Refresh
P [* TestEvent __.{,..c,
» [ Test]N Page
P [ Testjn-2

Meta Keywords:

2.  Enter Page Title, Navigation Title and Browser Title.
Be consistent with format — first, middle and last name; honorifics, degrees, etc.

3. Enter Person fields:

a. First Name
b. Middle Name
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Last Name

Display Name (Directory Page)

Title or Position (2 lines, Directory page)
Department or Group (3 lines, Directory page)
Photo (Directory Page)

Affiliation

User Defined

—S@ e oo

j-  Contact Information
a. Phone (2 lines, Directory Page)
b. Email (Directory Page)

k. Place

|.  Category 1 thru Category 3

STEPS: To populate the people details page with content, insert these components under the
“Page components folder”:

In Experience Editor:

1. Click Add Component icon (upper left).

PRESENTATION BEXPERIENCE VERSIONS OPTIMZATION VIEW

= Lollege or Natural science Undergraaguate
‘ Molecular Biology ‘ S

2. Click “Add here” for “PersonBody” area — hover over “Add Here” to see where the
component will be added.
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To verify that you are clicking the correct “Add here” location on the page, hover over the
button and hold for the tooltip that displays.

Do NOT select “MainContent” location or the page will not display correctly.

+ Add here |

+ Add here

3. Add a Header component and Rich Text component for each section of content to be
included on the page. Specify “Create New Content” as the data source.

4. When all components are placed on the page, SAVE and close the EE tab.

In Content Editor:

5. Click the “Page components” folder to expand it.

6. For each Header component, in the Header section, select the appropriate predefined
header text in the dropdown menu. SAVE.

4 238 staff-directory
> € Page Components

4 [%] bales-merrijo

= Title:
4 [[7] Page Components
%, header-bio Biography o
E] bio

7. For each Rich Text component, enter appropriate section content. SAVE.

8. Publish the changes.

1.24.1 People Details Page — Header values (For Admins)

ADMINISTRATORS ONLY: To create a new header, follow these steps:

Navigate to /sitecore/content/MSU/sitename/sitename Configurations/People Headers
Right click on the folder

Select Insert to display the menu

Select “Single-Line Text Config”

Enter the Key and Value fields

agrwON=
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4
»

A

(@ Alert Levels

&l Colleges

{@ Conzacts

{@ Grid Configurations
(@ Hero Text Size

{@ Highlight Styles
@ lcons

{& Image Alignment
(@ Image Facts Style
{@ Image Orientation
{@ Masthead Colors

{& Mixed Content

v v v Vv Vv Vv VvV Vv Vv Vv Vv Vv v

& News Topics

[N

&) People Headr—
Insert
&$ Area of Ex
Search

@)

&3 Biography
Duplicate

&3 Links |j']
&3 Media Ass R Delete

&3 Publication ™ Rename

&3 Selected P Copying
&3 Social Sorting
» (@ Side Tab Typ / Edit
» @ Social Media Eonsia
» @ Text CTA Styl g Scripts
4

&l Text Stvles

{@ Mixed Lontent
@ News Topics
() People Headers
ich Area of Expertise
i Biography
&3 Links
&3 Media Assets
&9 Publications
s Selected Press
&3 Social
@ Side Tab Types
{@ Social Media Platform
{@ Text CTA Styles
{@ Text Styles

Thumbnail Sizes

_.

Config Foldgr

-

Created from:

Item owner:

Single-Line Text Config

Checkbox Config

Checkbox Config Shared

ABD-2770-42.

Multi-Line Text Config

Headers

e/templates/

Multi-Line Text Config Shared
Image Config

Image Config Shared

DropTree Config

DropTree Config Shared ¥l

TreeList Config A\admin
TreeList Config Shared

General Link Config -

General Link Config Shared
Rich Text Config

Rich Text Config Shared
DateTime Config

DateTime Config Shared
Date Config

Date Config Shared

CodeBlock

[unknown]

sitecore\admin

Configuration

Value:

Area of Expertise

Base Configuration

Key [sha

Area of Expertise

Sitecore CMS Components User Guide
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1.25 Photo-Caption Carousel
Description
Usage:

More info:
e This component is global. There are four variants for this component:
— Center
Center Portrait
— Left
— Right

Example:

STEPS: To add or modify the content (data) for the component:

1. In Content Editor navigate to the component under the Page Components folder of your
page and select the Component in the tree.

2. In the right pane, select the Photo Alignment

Photo-Caption Carousel

Photo Alignment:

Left

Center

Center Portrait

a. If you are selecting either the Left or Right alignment the Title and Description fields
will be displayed

b. Horizontal Line checkbox will display the green line between the title and description
when checked
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Item owner: sitecore\Admin

Photo-Caption Carousel

Photo Alignment:

Left

Title:

Photo Caption Carouse

Description:

This is the photo-caption carousel.

| Horizontal Line

3. Right click and select Insert > Photo

P @ MIXED LONent 3 Lol

4 a Photo-Caption Carot~~'

Insert » (@& Photo
g
i Search [ insertfrom template
& Photo 2 e
[]) Duplicate

[

» & side Tabs Componet . :
* P Photo Caption Carouse

X Delete
» & Tabs Component

E] Rich Text = Rename

= hh e _ Description:

- Vin »

&| Rich Text - Header Copying

in This is the photo-caption carouse

» [ tdbtest Sorting £ 3 : [
» [ mitest # Edic
» [ mcrest @ Refresh

» [) NTLtest

# HAarizAanrallina

4. Choose the orientation of the photo you want to add.

5. Choose the Image for the various view ports. Desktop Image is mandatory and will be used
for the view ports that do not have an image selected.
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Orientation: /

Portrait b
Image - DM
Browse Properties Open media library Edit image Clear Refresh

/Assets/MSU/Images/20200422DLTU4009/1587410775656

|

Image - Ty

Browse Properties Open media library Edit image Clear Refres

Image - M

Browse Properties Open media library Edit image Clear

(i)
f(
i
a
o)
D
L]
b
i

Caption:

Sed porttitor lectus nibh. Vestibulum ac diam sit amet quam vehicula elementum sed sit amet dui.

[Above photo is not correct for Caption field — recreate]

6. Fill in the Caption for the photo by selecting “Show Editor” to expand the Rich Text Editor
7. Repeat the above steps until all photos have been added
8. Make sure to Save and Publish the changes
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1.26 Quote

Display a direct quotation and author

Usage:
o Display a quotation on any page

More info:
¢ Quote is the simplest component to use — it has only two fields and can be used globally,
i.e. placed in site’s Global Components and used as a data source in any components

Example:

STEPS: To add or modify the content (data) for the component:

1. InContent Editor navigate to Page Components folder of your page and right click. Select

Insert>Quote
4 4 Lanaing
b 2018 ftem ID: {4D69C813-92E:
» 2019 ) Ad- Coming Soon jeath-d
[l Page Components @ BoxCTA e
4 [Z] spartan-death-detective a® ‘Hero:Banner
@  Her
> S . fremplz
> B Page Comnana =2 Hero Banner - Story
» ¢ 2020 Insert 4 ]
W . y T) Highlight & €N,
T Q  Search
» [y news s
[®] Image Facts foster

» [ Newsletter Ur [ Duplicate

& Introduction
b [ Test ® Delete .
] LinksLi
» Oy ViewAll = Rename &1 Links List
] @] Medi
» [ webcams Copying » |B] Media
» B womens golf\ Sorting ; A Media Contact
b J MSUToday Come  »  Eqpe [B] Media - Story
» ¥ MSUToday Confj M1 Console & Mixed Content
2]
@ Dictionary S Ed Newsletter Subscribe
: By Scripts M|
iZ] Global Components _(C=oci neca
& Refresh
» (il Global Alerts & Quote
» J Global Authors

E] Rich Text-5tory

o1 (Slakhal 211 ta Artinn

y P Texx(TAs

-

Media Library  Workbox Insert from template

2. Giveitaname
3. Click on the component and in the right pane fill in the appropriate fields
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Item path: Isitecore/content/MSU/MSUToday/Home/Landing/Naeim Test Story/Page Components/Quote
Template: Isitecore/templates/Feature/Shared/Components/Quote - {D683EF5C-6D18-4424-A05F-BECAFD956E05}
Created from: [unknown]

Item owner: sitecore\Admin

Quote:

This is a test Quote that | putin the middle of the text.

Aztriburion/

4. Save and Publish the changes
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1.27 Rich Text

Add rich text content directly to a page. Rich text refers to text, formatting like bold and
italic, HTML heading tags, images, media, files, videos, etc.

Usage:

More info:

e The Rich Text Component is global. There are three different variations.
— Full Version — available for Body Content, Tabs and Accordions.
— Modified Full Version — full version with additional functionality for the Story Page

(discussed in the Story Page section)

— Lite Version — provides a limited number of styling options

¢ Components that provide the Full Version rich text editor:
- TBD

Example:

STEPS: To add a Rich Text component to a page:

In Content Editor:
1. In content tree, navigate to the Page Components folder of your page.
2.  Right click Page Components and select Rich Text from the list of components.
3 Click Show Editor and enter content. Use any of the special features below.

As with any Rich Text component:

— Paste text as Plain Text

— Use SHIFT-ENTER to create blank lines

— Can add links, highlight text and apply Heading tags, change font size, etc.

4. SAVE

In Experience Editor:
5.  Place the Rich Text component on the page
6. SAVE and close EE tab.

In Content Editor:
7. PUBLISH the component.

1.27.1 Rich Text Full Version
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Rich Text Editor

Gl MATACACY W31 . MRt At S g 0

1.27.2 Rich Text Full Version — Story Template

STEPS:

RAMEAT O TRSIE 6 RAGIOr AT doumpea I

TS 0 GRS QIR S 65 URIGRS RRGHETR QD Gt

I S 6. W00
it oo 1)

103 ROGILQr AERamiad (020!, S10in St S0 (5ks. VARmes SkE0Al AR Rasi i COmIDr vob oA S4d LOBllDr et

1.27.3 Rich Text Editor — 2-column

More info:

e The content author can split the rich text editor’s content into two columns, this feature is
only available in Full version Rich Text Editors.

STEPS: To add the two-column layout to your rich text editor follow these steps:
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1. Click on “Show Editor” in the right pane of the content editor to open up the RTE

Content - The main content for this component:

Show edito Suggest fix Edit HTML

2. Click on the arrow next to the “Code Snippet” icon to expand the dropdown menu
3.  Select the Two Columns Snippet from the dropdown menu

Rich Text Editor

& n R E BN DOC  BEUSLE-O- %3 o 0

£ -

B 7 U WS E FF o % ox Ao = o B A -9

4.  This will insert two placeholder items for you to insert the content for the columns
respectively

5.  Type in the desired text in the respective column

Rich Text Editor

- 8 BB ®W B8 0 &9 <> A ) B 8- B | Q- ® &~
B ZE | Z 2 E E g X2 x| A O | = B B d T O

~
=
I
Ml
il
]

The left column within the rich text editor
The right column within the rich text editor

1.27.4 Rich Text Editor — Buttons

More info:

e The content author can add a button style CTA in the rich text editor.
e This feature is only available in Full version Rich Text Editors.

STEPS: To add the CTA button t to your rich text editor follow these steps:
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1. Click on “Show Editor” in the right pane of the content editor to open up the RTE

Content - The main content for this component:

Suggestfix | Edit HTML

2. Insert a link (Sitecore or external link)

Rich Text Editor

seseos o0 Be@Ees o w30 08

B /7 | » HOE K e XX A0 =0 BEA-T-VeO

3.  Define the item you want to link to or the url for your external link

= Hyperlink Manager X

URL  http://google.com [éﬂg

Link Text  Primary Cta text
Terget  None

Existing Anchor  None

Tooltip

4.  Highlight the text for the link you want to turn into a button
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Rich Text Editor

Y EER R E B G S D gasgasm & B Q €8
B 7 U === |5 I 0 % x|A-0-|= &3 k- V-V O

5.  Select the desired button style from the “Apply css” dropdown

Rich Text Editor

=AY EEEWE eSO BEAABE BB Q@ B

B 7 UE=E=E2|£ i EE 8 % x | A0~ | = 8 B ATV O % d
Primary Gia Text =

Secondary CTA Text

Secondary Button

|

6. Accept Changes, Save, and Publish
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Rich Text Editor

O
s A Y BEEEB®BEESID O BRABAE BB Q@ B
B/ UEsE=ss8 | = &%

abe Xz Xx* A~ O~

I

B& V- VO =

Primary Cta Text

Secondary CTA Text

Design HTML

fees

1.27.5 Rich Text Editor — Font Colors

More info:

The content author can add change the font color in the rich text editor.
This feature is only available in Full version Rich Text Editors.

STEPS: To change the color of the font in your rich text editor follow these steps:

1. Click on “Show Editor” in the right pane of the content editor to open up the RTE

Content - The main content for this component:

Suggest fix Edit HTML

2. Type in the desired text and highlight it
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Rich Text Editor

=AY B EWE B D BB B8 %8 Q" @® B~
B 7 USE == 28 £ IEE e 2 x| A- O~ | = 8 B &R T O

This is the [l = eI appear in the left column
Secondary Cta

This is the text that should appear in the right column

Primary cta

3. Click on the Foreground button to expand the color palette dropdown

Rich Text Editor

=By BEEEE B R D-C- B ES B8 %8 o © 8-
BIQ%%E%% Xz x* A~ O~ Q*,a‘bj,w‘yo
H B
=}
This is the text that should appear in the left column E = = T HHHE
Secondary Cta
i EEEEEEEEN
L B EEEER
Add Custom Color...

This is the text that should appear in the right column

i

Primary cta

4. Select the desired color

This is the text that should appear in the left column

Secondary Cta

Thls is the text that should appear |ﬁ the right column

Primary cta

5. Accept changes, Save, and Publish

1.27.6 Rich Text Lite Version
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STEPS:

Rich Text Editor O X
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1.28

Sitecore CMS Components User Guide

Side Tabs

Vertical list of topics (tabs) that when clicked, open a right pane of related links (two
columns) and optional images. Only one topic’s links are viewable at a time.

Usage:

Displaying a large amount of related content in a compact way

More info:

The Side Tab component functions like a standard set of tabs, but content opens in a pane
to the right of a topic (tab) rather than below it, and there are no rounded tab corners.
Content is well-organized and highly scannable in the Side Tab format, making it intuitive
and easy to use.
Side Tabs are displayed in the order in which they reside in the Tree.
The tab content is arranged in 2 columns, although content can be added to either column
at content author’s choice.
Side Tab has three content pane formats:

o 2 Column Rich Text — example 1

o 2 Column Rich Text with Image — example 2

o Image with Description and CTA — example 3
A Side Tab can use any combinations of the sub-component formats.
Although a rich text container is provided for the tab content and technically it could contain
images or other non-text content, the assumption is that only text links will be used.
Tab content typically consists of pairs of Titles (links) and Descriptions, using single-
spacing or 1.5 spacing between them. The Steps below explain how to accomplish both.
Note: The MSU website uses 1.5 spacing in its Side Tab components.
Tab contents can be split into a 2-column format — see page component “Two-column
Container in Tabs”.

Example 1: 2 Column Rich Text

Source: MSU About page https://msu.edu/about

Initiatives & Distinctions

History

Connect with MSU

Businesses & MSU

Board of Trustees

Bios and information about
meetings, bylaws and more.

Office of the President

Presidential actions, initiatives
and communications.

Office of the Provost

Matters that affect academic
proarams. research and

Leadershi Associate Provosts
Resources g
— Complete list of campus Bios of MSU associate
leadership. provosts.
Leadership

Organizational Chart

Map of central
administration and
academic leadership.

Academic Governance

Faculty Senate, University
Council, committees and
more.

Accreditation
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Example 2: 2 Column Rich Text with Image

Sitecore CMS Components User Guide

MSU Activities

Activity Highlights Arts

Student Activities

Business

See what's happening at MSU

Making an impact on culture.

Solving global business
challenges.

MSU Research Team

Science & Technology

Leading the way in
discovery.

Conducting Research at
MsSU

Supporting research and
creative activity.

Example 3: Image with Description and CTA

Source: MSU Visit page https://msu.edul/visit

Things to Do

4-H Children's Garden
Abrams Planetarium
W.J. Beal Gardens
Beaumont Tower
Broad Art Museum
Bug House
Horticulture Gardens
MSU Dairy Store
Spartan Stadium

Wharton Center for
Performing Arts

of all ages.

A place of enrichment and delight for children

Visit page
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STEPS: To add or modify the component:
1. In Content Editor, locate the page in the content tree

2. To EDIT existing Site Tab component:
a. In content tree, click Page Components node to expand
b. Select Side Tab component
c. Modify fields
d. SAVE

3. To ADD new Site Tab component:

In content tree, right-click Page Components folder

Select Insert > Side Tabs Components

Give it a unique name

Mobile Tab Layout — in the dropdown, select how the Side Tab Component displays
in mobile view: Listing (default, stacked vertically), Accordion (expandable panels)

aoop

Item owner: sitecore\Admin

Side Tabs

Mobile Tab Layout:

Accordion

Section Title:

Vivamus magna justo, lacinia eget consectetur sed, convallis at teflus

¢ Green Line

e. Section Title — enter text that displays above tabs on left

Green Line — check to display a small green line between Title and content, both left
and right sides

g. SAVE

—h

SIDE TAB CONTENT:
4. To EDIT an existing a Side Tab sub-component:
a. Select a Side Tab sub-component from Side Tab Page Components node
b. Modify fields
c. SAVE

To ADD a new Side Tab sub-component — choose one of the following:
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» [M Photo-Caption Carousel

Side Tabs
» & Side Tabs Component
4 ) Tabs Component Insert » | & 2 Column Rich Text
1 Search @ 2 Column Rich Text With Image
E] [ Duplicate > Image With Description and CTA
=] ¢ Deles [ Insertfrom tempiate
» [ b test e Renap Section Title:
» [ mitest Copying » Vivamus magna justo, lacinia eget consectetur sed,
» [ mcrest Sorting .
» [) NTLtest 2 Edit ¥ Green Line

Note: Sub-component name serves as a query string that is added to the page URL when a tab
panel is opened. The URL + query string can be used as a link to the page and to open a specific
tab panel.

Example: https://msu.ga.sitecore.msu.edu/page-name#2columnrichtext

5. ADD: 2 Column Rich Text
a. Right click the Side Tab component and select INSERT > 2 Column Rich Text
b. Give it a unique name
c. Tab Title — (required) name of the tab, represents a category or topic for the tabbed
content, when clicked displays the tab’s content (in right pane)
d. Left Column Tab Content — in right pane, column 1 of content area, use the rich text
editor to add content.
Click “Show editor” to begin.
Example: the MSU website displays a series of links:
i. Enter pairs of Title (link) and Description (see Examples)
ii. See below on how to format the pairs
e. Right Column Tab Content — in right pane, column 2 of content area, use the rich
text editor to create content
f. SAVE

6. ADD: 2 Column Rich Text with Image
a. Right click the Side Tab component and select INSERT > 2 Column Rich Text with
Image
b. Give it a unique name
c. Tab Title — (required) name of the tab, represents a category or topic for the tabbed
content, when clicked displays the tab’s content (in right pane)
d. Tab Image — image that displays below the 2 columns of links; click Browse to
select an image from Media Library
e. Image Link — (optional) link destination for the image (may or may not match button
link destination):
i. Select link type
ii. For Internal link, select a page from the Tree
iii. For External link, enter fully specified path
iv. Description — button label, i.e. text that appears on the button
v. Target — Active Browser (destination displays in same browser tab) or “New
Browser” (destination displays in new browser tab)
vi. Click Insert
f. Left Column Heading — text that displays above column 1 in the content pane
Click “Show editor” to begin.
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-

K.

Left Column Tab Content — in right pane, column 1 of content area, use the rich text
editor to add content.
For example, the MSU website uses pairs of links as content:
i. Enter pairs of Title (link) and Description (see Examples)

ii. See below on how to format the pairs
Right Column Tab Content — in right pane, column 2 of content area, use the rich
text editor to add content.
Click “Show editor” to begin.
CTA Link — button link:

i. Select link type

ii. For Internal link, select a page from the Tree

iii. For External link, enter fully specified path

iv. Description — button label, i.e. text that appears on the button

Note: This value is not used for button label.
v. Target — Active Browser (destination displays in same browser tab) or “New
Browser” (destination displays in new browser tab)

vi. Click Insert
CTA Label — button label, i.e. text that displays on the button
Note: Unlike other components, the CTA Label is used for button text.
Green Line — check to display a green line under Title
SAVE

7. ADD: Image with Description and CTA

a.

b.
c.

Right click the Side Tab component and select INSERT > Image with Description
and CTA
Give it a unique name
Tab Title — (required) name of the tab, represents a category or topic for the tabbed
content, when clicked displays the tab’s content (in right pane)
Tab Image — image that displays below the 2 columns of links; click Browse to
select an image from Media Library
Image Link — (optional) link destination for the image (may or may not match button
link destination)
i. Selectlink type
ii. For Internal link, select a page from the Tree
iii. For External link, enter fully specified path
iv. Description — button label, i.e. text that appears on the button
v. Target — Active Browser (destination displays in same browser tab) or “New
Browser” (destination displays in new browser tab)
vi. Click Insert
Description — text that displays below image and explains this sub-component’s
content
CTA Link —
i. Selectlink type
ii. For Internal link, select a page from the Tree
iii. For External link, enter fully specified path
iv. Description — button label, i.e. text that appears on the button
Note: This value is not used for button label.
v. Target — Active Browser (destination displays in same browser tab) or “New
Browser” (destination displays in new browser tab)
vi. Click Insert
CTA Label — button label, i.e. text that displays on the button link
Note: Unlike other components, the CTA Label is used for button text.
SAVE
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8. NEW Side Tab Component only:
a. In Experience Editor, add Side Tab Component
b. SAVE and close EE tab
9. Drag and drop Tabs in the content tree so that they are in the correct order for display.

10.  Preview the page (optional): In Content Editor, on Publish ribbon, select Preview and verify
changes made

11.  Publish the Side Tab component.

12.  Verify changes in a browser.

1.28.1 Format a Tab Title and Description

More info:
e Tab content often consists of pairs of Titles (links) and Descriptions, using single (1-line)
spacing or 1.5 line spacing between Title and Description.

Single-spacing: 1.5 line spacing (MSU website):

Arts Arts

Making an impact on culture.
Making an impact on culture.

Business
Solving global business Business

challenges. Solving global business

challenges.

Environment

Creating a greener tomorrow. .
Environment

Creating a greener tomorrow.

Health

Health

Single spacing:

In either Left Column Tab Content field or Right Column Tab Content field:
e Click “Show editor”
e Enter Title text
e Single space (hold SHIFT key and press RETURN key)
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e Enter Description text

e Create the Title link and bold the Title text
e SAVE

1.5 line spacing:

In either Left Column Tab Content field or Right Column Tab Content field:
e Click “Show editor”
e Create the Title and Description using Single spacing instructions above
e Click “Edit HTML”
e Single-spaced text looks like this — these are the HTML tags:
o <p>tag marks the start of a paragraph of text with default font
</p> tag marks the end of a paragraph
<a> tag marks the start of a link
</a> tag marks the end of a link
<br /> tag inserts a single line break
<strong> and </strong> tags mark the start and end of bolded text

O O O O O

<p><a href="https://msutoday.msu.edu/arts/"><strong>Arts</strong></a><br />

Making an impact on culture.</p>

<p><a href="https://msutoday.msu.edu/business/"><strong>Business</strong></a><br />
Solving global business challenges.</p>

<p><a href="https://msutoday.msu.edu/arts/"><strong>Arts</strong></a><br />
Creating a greener tomorrow.</p>

e Remove <p> tag that appears before <a ... tag and place at beginning of Description
¢ Remove <br /> tag that appears after </a> tag

Resulting HTML code is:

<a href="https://msutoday.msu.edu/arts/"><strong>Arts</strong></a>
<p>Making an impact on culture.</p>

<a href="https://msutoday.msu.edu/business/"><strong>Business</strong></a>
<p>Solving global business challenges.</p>

<a href="https://msutoday.msu.edu/arts/"><strong>Arts</strong></a>
<p>Creating a greener tomorrow.</p>

e SAVE

e Preview and verify that format is correct
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1.29 Single Mixed Content with Social Media
Description

Usage:

More info:

Example:

STEPS:

(TBD)
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1.30 Social Feed
Description

Usage:

More info:

Example:

STEPS:

(TBD)

Sitecore CMS Components User Guide
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1.31 Social Media Directory

Description

MSU.edu use only: Display a list of MSU units and their social media accounts.

Usage:

More info:

e This component is for managing a directory of social media sites for a large unit. The

assumption is that there are multiple units in the organization which each have their own
social media sites.

Example:

Michigan State University

On the university-wide social media accounts, you'll find the latest Michigan State University
stories, news and highlights — everything from Spartan pride to world-changing research.
#SpartansWill

00000

wr

D>

Admissions @ O O

Learn more about Michigan State University and its highly ranked
academic programs, student organizations and important news and
events on the Admissions social media accounts. It's good to
#BeASpartan.

Alumni Office @ @ @ () o

The Michigan State University Alumni Office shares the collective
impact of nearly half a million Spartans worldwide. Check out alumni
stories and upcoming events on its accounts.

Athletics MM
STEPS:
A For Admins and Advanced Users

Social Media Directory
Social Media Directory
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REVIEW ANALYZE PUBLISH VERSIONS CONFIGURE P ATION y VIEW MY TOOL

Save Dasails Reser Preyiew Allases LaYOUt Details
The detalfs of the assigned layouts, controls and placehoiders
b & Global Configuration A
< @ nsu ™\ This tab displays the shared layout details that ace sed by every version of the (tem.
o @10 j | The Final Layout tab dispiays the combined presentatian detalls for this speofic version
[ehared + versionad detats)

» Erre Placeholdar Settings
» ) Pege Comporents
feem 1D:
’ el
L | ltem na
4 Item pa
» t
Templa
4 @ NSU Componsr »
’ MELC Action Created -
1 = Main Navigation - Mobile
MSU Fuerts Itarn o4
- out
MSL Foote:
= Footer Links
N MSU Header = -

Cantent Editor

o # Contant Editor

|  Administrator

VERSIONS CONFIGURE PRESENTATION SECURITY
Device Editor

Set the layouts, controls and placeholders for this device

Layouts/Feature/Shared/Page/BootstrapLayout o

FINAL LAYOUT Controls

Layout Details

The details of the assigned layouts, controls and placehc

a Placeholder Settings
Masthead

-
| j aMasthead - Mobile

= Brand Bar

@ Brand Bar - Moblle
= Main Navigation
= Main Navigation - Mobile
m Footer Layout
HeayIBy = Footer Links
£ k
Hemna m Footer Contacts
m Footer Social Media
Item pa m Footer CTAs
= Footer Secondary
Templal ] :
= Social Media Directory Listing
Created = =

Item ow B

SN Controls
n cance’
o <

.

Renderings/Feature/Shared/Components/Social Media Directory Listing
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® Meda
® \sedia Cantact
® Mived Contant
® Newsletter Subroribe

® iow-Laptien Carousel

® Socul Feed

® L0 Meds :m-:ﬂul‘“,mug

Add to Placehclder

Open the Propertes disiog box immediately

et Erttor

Sacial Media Divectory Listing

Cancet

Sitecore CMS Components User Guide

ut
phiHoader

AeetBar

ontent/MSU/MSUMSY
deee /M e o

ot Mt .
Datsscurce: /sa tent/MSUMSUMEU
ComponentsMSU Mesder/Masthesd

Brond Bar
Maceheicer

aneiw
elcantent/MSLIGIoba
bal Header/Srand Bar

Blyemholder ML Mairhase stior
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- JuULIal JIIGIT

un

= Tabs Component

Add to Placeholder: | phMainContent

Open the Properties dialog box immediately. Cancel

OR from the Experience Editor

PRESENTATION EXPERIENCE  VERSIONS e

Layout Details

= - % Explars
Bj‘ | 2| e EXpIOrE = \‘___; f_-:‘ The details of the assigned layouts, controls and placeholders.
Edit Preview &% Debug Final Layout Details Reset
=ye SHARED LAYOUT FINAL LAYOUT
> Home > Social > n Edit
= Main Navigation =
m Main Navigation - Mobile
For: Parents | Students | Alum m Footer Layout
m Footer Links
- m Footer Contacts
ﬁ MICHIGAN STATE UNIVE % >
m Footer Social Media
m Footer CTAs
m Footer Secondary
About | Admissions | Acaden \ m Social Media Directory Listing [
Edit Copy Tc
MSU.edu > Social Media Directory w‘
P Controls Placeholder Settings
rint = o

Edit CopyTo

ﬁ. MICHIGAN STATE U n Cancel

FACILITIES & SAFETY LOGINS
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nal tayout . Deg!

Device Edi Select a Rendering

Select the rendering that you want to use. Click Select to continue.

Set the layouts,

Sitecore CMS Components User Guide

ithinct Layout Search Renderings... Add
Edit ‘ -
® Mixed Content Edit
Placeholder S ®m Newsletter Subscribe =
p I
Parents | Stu m Photo-Caption Carousel coonalzs Appl
® Quote Change
MICHIGAN S ® Side Tabs
m Social CTA Remove
® Social Feed
® Social Media Directory Listing Test l
® Social Share
® Tabs Component Move Up
edu > Social M b Text Move Dowa
® Text CTAs
®m Text Fact
\ Text Facts Grid -
Add to Placeholder:  phMainContent
¢ Open the Properties dialog box immediately. Cancel Cancel
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Device Editor

Set the layouts, controls and placeholders for this device.

Control Properties

A W
General ~

5] St Placeholder s iJ: pply

GAN ) 2
Data Source g#ored]:
Broyse Build query Paste query Clear
@ P

< i A
bocial

Caching [shared]:
Cacheable

Clear on Index Update

Vanr hv Nata

Go to
/sitecore/content/MSU/MSU/MSU Components/MSU Social Media Directory/Social Media Directory

Categories that will be used to filter
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NAVIGATE REVIEW ANALYZE PUBLISH VERSIONS CONFIGURE PRESENTATION SECURITY VIEW MY TOOLBAR

H < 3 Insert from template (1 0of1) 4 3 Copy to x = Rename A Up
v S
Save Editw v Duplicate « ¢ Move to Delete =] Display name v Down
’ m Q
4 {J MSU Components - Show editor Suggest fix Edit HTML
» { MSU Call to Action Learn more about Michigan State University and its highly ranked academic programs, stut

y accounts It's good to #BeASpartan.

¢’/ MSU Events
{J MSU Footer

» {¢J MSU Header

4 {J MSU Sacial Media Directory

4 [J Directory Categories

@ |Institutional

N\
@ Colleges and Sc Category:
@ Locatlons and Destinations _
Institutiona
@® Campus Life and Services L\}
@ Offices Link:
4 & Social Media Directory ey Gry s e e SeE STy Hcartama

-

& _Michigan State University
& Admissions

a ., A e
@ Alumni Association

‘ = ) Social Platforms

Link field applies to the Title
Social Media section to be filled, if empty it will not display Pinned
Sorted in the tree alphabetically

NAVIGATE  REVIEW  ANALYZE {  VERSIONS  CONFIGURE  PRESENTATION  SECURITY  VIEW MY TOOLBAR
< Inse: emplate (1 of 1) 4 3 Copyta x = Rename A Up R First
= Edite = 3 Move ro = Display name v Down ¥ lam
-
Content [RS8
4 @ MSU Componen M Soaal Media Lirectory item
N A

Wi Is Pinned

-

Tatle:

Descriptior
iggest i SHIM

eam more about Michigan State University and its nignly ranked acedemic programs, student organizations and important news and events ¢
accounts. IN's good to #sBeASpartan

Categary
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Institutiona
Will be omitted from the main list

— HOME NAVIGATE REVIEW ANALYZE PUBLISH VERSIONS CONF PRESENTATION SECURITY VIEW MY TOOLBAR EVELOPER
H < & Social Media Director... (1 of2) + ﬁj T Copy to x = Rename A Up A First
v = -
Save Editw ) Insert from template  20f2) § Duplicate v % Moveto  peletew [7] Display name v Down ¥ Last

-
Content Q
W TN P8l  Social Media irectory Listing
) MS! eader
4 ) MSU Social MedIa Directory .
- Ing»mtional Social Links:
» {J Directory Categories
4 & Social Media Directory Social Media Directory/_Michigan State University
& _Michigan State University
- Institutional Image:
@ Admissions
Br Pr nediz y cl
& Alumni Assoclation s sl =
@ Assoclated Students of Michigan State Uniy /images/Global/helmet
& Athletics
& Breslin St vents Center \\\\lr
& College of Arts and Letters 4
& Eli and Edythe Broad Art Museum
& Ell Broad College of Business
& Human Resources
» {J MSU Social Media Links :
e te e
» @& MSU Configurations
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1.32 Social Share

Description
Usage:
More info:

e Social Share component can only be added into the Two Column Container. The steps are
similar to Contextual Navigation, except that Social Share does NOT require any content as
this component connects to a third-party plugin. This component can only be added through
the Experience Editor.

Example:

Connect With Us

00000

STEPS:
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Select a Rendering

Select the rendering that you want to use. Cick Select to continue.

Contextual Navigation Rich Text Social Share

[i it

Open the Properties dialog box immediately. ﬁ Cance! itl

DR_TEsST pgge e
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1.33 Story Landing Page / View All Pages
Description
Usage:

More info:
e The View All page is where all stories are “listed”.
e The visitor can toggle between the Grid View and the List View.
e When viewing the Death category, the visitor view defaults to the List view, but the visitor
can switch to Grid view.
e The View All page has a filter section.

Example:
ﬁ. MICHIGAN STATE UNIVERSITY For: Students | Alumni | Faculty & Staff Apply | Visit | Give
MSUTODAY a
Arts | Business | Campus | Envir n calth ife | Science and Technology | Sports | View All
CLEAR X =
02/01/18 - 06/15/20 ~ Categories - Types - Colleges -

Jun. 8, 2020

DISCOVERING THE GOLD STANDARD
THINKING BEYOND THE BOX YOU ARE A SPARTAN OF CANCER DRUGS

STEPS: TotellSitecore whichpagetouseforViewAll,goto: (TBD)

A For Admins and Advanced Users:
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1.34 Story Page [story template]

Description

Usage:

More info:
When a Story is created a page is generated using the Story Template.

CAs can add components to the page much like any other page. However, the template
also has many specific fields that will be explained in various sections.

“Hide Breadcrumb” is to—as the name suggests—hide the breadcrumb on the page. All
pages have a breadcrumb by default.

“Unlisted” checkbox is used to prevent the story from appearing in any of the navigation
tools. This is mainly used to publish a story but not necessarily make it public, for example
if a review is required by a party outside of the organization.

STEPS:

4 @ MSUToday

i@

&/v v v v v

Home

\ Errors

[l Page Components

] Story Layouts

[£) Example Story

[) for-media

[y Landing

() new-
[ae

-~

&l 2

g2 O

¥ v v v v v v v v v ¥
% L,
“s_.
)

2 Vi
2l 2 -
{2
: >
l 2
E @
Ol 2viv
A . 2nnn

Insert

Search

Duplicate

Delete
Rename
Copying
Sorting
Edit
Console
Scripts

Refresh

I__{j news

Quick Info

Item ID:
Item name:

Item path:

Page

Story Page

Story Landing Page

Insert from template

Page Title:

news

Navigation Title:
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Breadcrumb

[C] Hide Breadcrumb

Story Page
[] Unlisted

Story Type:

Story

Title:

Story Title

Subheading:

Story Subheading

Authors:

1.34.1 Story Type

More info:
e There are two Story Types:
— Story
— Featured Event
e The “Featured Event” story type, once selected, will trigger the display of a stylized date on
the page.

STEPS:
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Breadcrumb ~

(] Hide Breadcrumb

Story Page ~

(] Unlisted

Story Type:

Story v

Featured Event

1.34.2 Date, Title, Sub-Heading

More info:
e CAs must enter the date for the story, this date will be used by the “NewsMover” feature to
sort the story into the correct folder structure.
o Title of the story will be marked with <H1> tag and hence the CAs should avoid using H1
when entering content through the “Rich Text — Story” component.
e Subheading displays below the title. It is advised to keep this as short as possible.

Example:

p

May 17, 2020
/ £

Second Story Title -

Subheading of my second story that will display right under the
Title

STEPS:
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1.34.3 Authors

More info:

e CAs can choose Authors from the multi-list by either double clicking on the desired author
or using the right facing chevron.

e Author can be removed using double click or the left facing chevron.

e The order in which authors appear is determined by their order in the “Selected” column.
This order can be manipulated using the up and down chevrons.

o To add/remove/modify an Author from the list, refer to “Contact Data Source” section in this
document.

Example:

142 |Page



University Communications, Michigan State University Sitecore CMS Components User Guide

By: John Doe and Jennifer Orlando

Madia Contacts

Jennifer Orlando & Matt Larson Download Assets «

STEPS:

A For Admins and Advanced Users:

£ ﬂ Q o T

Subheading:

1.34.4 Contacts

More info:
e CAs can choose Contact(s) from the multi-list by either double clicking on the desired
contact or using the right facing chevron.

e Contact can be removed using double click or the left facing chevron.

e The order in which contacts appear is determined by their order in the “Selected” column.
This order can be manipulated using the up and down chevrons.

e CAs can also determine the Media Contact title using the field with the same name.
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Example:
By: John Doe and Jennifer Orlando
/
Media Contacts
Jennifer Orlando & Matt Larson Download Assets ~
=
STEPS:

A For Admins and Advanced Users:

To add/remove/modify a Contact from the list, refer to “Contact Data Source” section in this
document.

>

v
>

4 & Mudin Lieary islayStadium
< v

e

1.34.5 Assets

More info:
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¢ |[f the Story has assets to be made available for download, the CAs can use the multi-list to
select the assets that are to be included with the story. CAs can use either double click on
the desired item or using the right facing chevron to select the asset. Asset can be
removed using double click or the left facing chevron.

Example:
By: John Doe and Jennifer Orlando
Media Contacts
Jennifer Orlando & Matt Larson Daumload Ascots
Story
\Szels:
S Nedia | = ¥ izlayStadium °»
< v
» O Assers
-~ m

1.34.6 Categories

More info:
e CAs can choose Categories from the multi-list by either double clicking on the desired
contact or using the right facing chevron.
e Category can be removed using double click or the left facing chevron.
e These Categories are exactly the same as those appearing in the MSUToday navigation
bar.

Example:
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By: John Doe and Jennifer Orlando

Media Contacts

Jennifer Orlando & Matt Larson Download Assets ~

3 2

STEPS:

Cotegories

A Selected
) ~
wirenment Arss
Health € Campus v

Business

Colleges:

1.34.7 Colleges

STEPS:

Colleges:

Select ol Ceseiett s

nd Natural Resources

Thurmbneil - After browsing an imege. you must dick somenhere on the imege then click Save:

Open media litvary Edit imag)

1.34.8 Thumbnail
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More info:

e Thumbnail is a mandatory field for the story template. This is the image used in the View
All page, the Related Story rollup or anywhere else a link to the story needs to appear.
e This field uses Advanced Image Tool which will be explained further in the next section.

Example:

College of Communication Arts and Sciences
College of Education

Collegiate Employment Research Institute
Communication Arts and Sciences
Education

Eli Broad College of Business

Eli Broad Graduate School of Management

Thumbnail - After browsing an image, you must click somewhere on the image then click Save:

pen media library Edit image Clear Refresh

3d to austin f@r r

"

o
o
S

Units - This is for backend and reporting only:

Select all Deselec
Select al Desele

:dia Links
STEPS: To choose a Thumbnail image for the story:

First click on Browse. You can choose to toggle between “List View” and “Tree View” from the
icons in the upper left corner.
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Select Media

All image files
Nedia folder: /media library
All videa files

My im3ges

Recently uptoaded images e . *
Recently upioaded by me v
MsU2 m

2 =

ch-parmmer-marketing hpuzh

fepcuiurs ang Napical Seprces

Form

Sitecore CMS Components User Guide

Select 3 file to preview

&)

ch-colisreral

an)
)]

ch-stare

TR ST

S Ecoadiciusoum

Select the image you want and click on Select.

Select Media

Media items

Mediz folder: /media library

4 & Media Library

20-homepage

» 3 D W e
» (o) Experience Explocer
»  Files

m Hero

'!:' Isle
W JosHi=tner

P JosStuderts
» ) kirks

yStadium

Bl Screen Sh
Screen Shot
Skelezon

| I

& spartan-helmet

» AINESS

JoeHefner

Nome: JoeHefner

Typ= Image

Cancel

AT L )
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1.34.8.1 Advanced Image Tool

After you have selected an image, you must click somewhere on the image to identify the focal
point. Then click Save.

ONFIGURE  PRESENTATION  SECURITY

Once you click Save, the correct size image is generated and displayed.

-

PUNIEE 3T - NTEr DPOWENG 21 IMSge. YOU MUST CICK SOMRATIRNE DN the IM3ge then Ziics Seve

You can modify the focal point by clicking on the thumbnail of the image. A red dot will indicate the
selected focal point. The output image will also change to display a preview of the final output.
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Make sure you save any changes.

1.34.9 Backend Tags

More info:

Backend tags are used in the backend and do not have a visual representation on the
page. These tags are only available on MSU and MSU.Today

They include:

— Units

— Backend Tags

— Focus Areas

The Units field contains “Degree Granting Colleges” which also appear inside the Colleges
filter on the View All page.

If you want the story to appear as part of that filter, you must make sure to include one of
those colleges in the selection you make for “Units”

STEPS:

1.34.10 Hero Banner

The Hero Banner of a Story is like the regular Hero Banner with only minor differences.

The only fields on the Story Hero Banner are:
— Background Video

— Desktop Background Image

— Mobile Background Image

— Youtube Video ID
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— Play Video In Lightbox
e The Hero Background Video takes precedence over all images and the YouTube video.

¢ The Desktop Background Image is a mandatory field and acts similarly to the Thumbnail
image field (section 1.35.8) This field automatically generates the necessary images for
both the Desktop and the Mobile view ports.

¢ |f you wish to overwrite the auto generated Mobile version of the background image simply
select the desired image in the Mobile Background Image field.

¢ The Youtube Video ID can be populated to play a video from Youtube.

o The Desktop Background image will be displayed on the page with a play button
superimposed on top. CAs can choose whether the video would play inline or in a lightbox.

Desizop Background dnage - Afler browsing 3n image. you must click samestiare on The image ten <iick Save:

Properties Open medis iibrary

B -

o~ vl

151 |Page



University Communications, Michigan State University Sitecore CMS Components User Guide

Lightbox:

1.34.11 Social Share
More info:

e Stories will automatically get a Social Share component. This cannot and should not be
modified by the CAs.

Example:
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May 17, 2020

Second Story Title §

Subheading of my second story that will display right under the
Title

Donec sollicitudin molestie malesuada. Donec rutrum congue leo eget malesuada
Mauris blandit aliquet elit, eget tincidunt nibh pulvinar a. Curabitur arcu erat,
accumsan id imperdiet et. porttitor at sem,

Curabitur aliguet quam id dui posuere ¢ it. Praesent sapien massa, convallis a

pellentesque nec, egestas non nisi. Don icitudin molestie malesuada.

Curabitur non nulla sit amet nisl tempus allis quis ac lectus.

Donec sollicitudin molestie malesuada, Mauris
blandit aliquet elit, eget tincidunt nibh pulvinar
a. Curabitur arcu erat, accumsan id imperdiet et
porttitor at sem. Cras ultricies ligula sed magna
dictum porta.

Vestibulum ante ipsum primis in faucibus orci

luctus et uitrices posuere cubilia Curae; Donec

alit nonoe auctar cit amat aliouam val

1.34.12 Story Content

More info:
e Story Content is put on the story page using the Rich Text component.

STEPS: To add the component to a story, open the story page in the Experience Editor.

Click the Add Component icon.

Click on the “Add here” button for the “StoryBody” placeholder.

VERSIONS OPTIMIZATION

[ e = e
'si \If & Dabug <3O o 12:38% > ?‘

T W ~ I TR TN W L ST A
- ora

Second Story Title §

Subheading of my second story that will display right under the
Title

* 800 nEE

434 8. vew rerdeniag 1o the SeyBody’ pRCetCios

Donec rutrum congue les eget

ibh pulvinar a Gurabityr a

Misadit Dimasant sanian macss arncallls o

Select “Rich Text — Story” from the popup and click Select.
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Select a Rendering

Select the rendering that you want to use. Click Select to continue.

Media - Story Quote

Open the Properties dialog box immediately. ﬁ Cancel

LUrapitul aigyueolL yuaill iiu Ul pusucIic idaiiuviL, rracoTiilL Sapicil rniassa, Lulivailiis o

Select the Content you have previously created or create new content.

To add or modify the component content data, go to the Content Editor. In the Tree navigate to the
Page Components of the story page.

To add content, Right click and select Insert>Rich Text-Story
Give it name

To modify the content, select the component and in the right pane click “Show Editor” under the
“Content” field in the “Rich Text — Story” section.
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» [ land-grant-roots =
» [& you-are-a-spartan
4 @14
4 [2) Naeim Story 2
4 [[] Page Comr thsert
/ @ BoxCT Q %ch
» [@ Hero B
[ Duplicate
@] Media
BB Newsle 8 Delete
& Quore = Rename
E] Rich Te Copying
4 [5) Naeim Test$ Sorting
4 [[f] Page Comr Z* Edit
» Hero B Console
@ Highlig By Scripts
(] Media & Refresh

> 4 Mixed Content
@ Quote
[E] Rich Tex: - Story

N\

[E] Story Text Section ¢

Sitecore CMS Components User Guide

Options

D) Ad - Coming Soon

» & Ad-ComingScon
3 BoxCTA

Hero Banner

Hero Banner - Story

Highlight

Image Facts

Introduction

Links List

Media

Media Contact

Media - Story

Mixed Content

Newsletter Subscribe

Photo-Caption Carousel

b e mEE DB LA A

Quote

23 Box CTA

Story

Hi
Story_

» o2
4 [ news

E

Rich Text - Story

[l Page Components

) Em Ay
[

Insert from template

» ¢ 2020 -
»
' % —m,m—‘ frem ID aF 78-98FB-EADIHOCDE3SE}
ltem name: Rich Texz or
Item pati fatn cenc/MIUMSUTodsy/Home/Larding!
Template: Linecora/emplates/ReaturaSUTodayComponante/Rich Tex: . Stary - &
Created from: funirown]
Ttam ownar:

TAY BACTLAG2F74D)

-

Conter /

fow editr

This is an H1 Test

Lovemipsiam cioker %1 amet. consecier Xipaong e Maus bianat alguet it apal tnzidunt ith puhinar 3 From egetiorke risin VashBuLm 32 diam St amet cuam veNCUa sismentum 3

ba 5t amet ot

Oarec sabctudn R @ 3t
opet m¥ezuada Mauns DisncR Yiqust ot eget trcidunt nich puvy

o iy elermertum sod il smet @ Dones retrum congus o
para

Our 20MIE 3108wl accirvean 1 ITpaciel ol potiior 3! sem Sed)

frortttor lectus nbh Wvamus suscif fodkr sget tede podteor skt ¥

Enter your content in the Rich Text Editor. The Rich Text Editor for Story is the full version of the
editor available to CAs and has many tools in the toolbar that can be used by the CAs to modify

the content.
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Design HTML

Accept Reject 2

st

While the tools are standard to many text editors out there and should already be familiar to the
CAs there is one special tool that has been custom built for MSU. It is called “Drop Image” tool.

1.34.12.1 Drop Image

More info:
o ltis advised that the image be placed AFTER a paragraph.

STEPS: To use the “Drop Image” tool simply position your cursor to where the image needs to be.

Then click on the indicated icon:
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Rich Text Editor
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a
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<

o Accept Reject

In the popup add the Caption in the appropriate field.
CAs can also choose to have the famous green divider display or not.

The “Enlarge Image” checkbox allows the CAs to decide if they want the drop image to be
expandable by the users.
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Insert Media With Lightbox

Select the imag 1o Insert. A ighthox will wrap the image.

by Assets e  Experience Explore e
o »
N #
P - e = A |
\
Al e E !
3
VA
Ll Haro Imageas slayStadium oatzine, safrudents
¥
s » .
% NS RT T -

Select the image and click “Insert”
The image will be inserted where you cursor was.
CAs should know that with the “drop image” the preview does not reflect the final view.

Preview:

feview  anavze RS VERSIONS  CONFIGURE  PRESENTATION  SECURITY  VIEW MY TDOLBAR

Rich Text Editor

- a BERE BB & 19 BLaAdB F-o | %E 0@ 5

B/ USSZ=B EEFTR M |B @B A - P O Axys.c homs - Cpantanrie | o=

LEes SRAE) Rnse MR Rores GUUE S0Qie 160 2078 anmadie Mo Cana! abaust 53, e9at leasd ohh o 2 SRRt Y IR LUTES © RSN 8 CRULISL & SR -
2 3] 1 s Deoss solcibulo moeste sleaada Caabihr non nula o1 2008) 0 00 ol 0w & Beho

2 biaod) b 1. c.0a! leckhuot nh cukie 2. Curdlu a Sl cunsin
ki e iy

12 s Do ist cras
i arc) hactua of unaes o
23 WIS B 22 1z

_ ]
(:.A;.l DACURN FCEATTAN ICAE. BI080 ST 100! G5 MXATTAES SASALH LXK 2028 150 DRI YAl e DR teaus
@ s
atectets adiciscion o) Quigus 2261 oisi cockus of LS . siamentin o 2
B S0 25 ULDRES Dmte
i 1223 QM3 265 (a3 dchm
&
s s e o hechay Coas ulbies Loyl sod maga detu sade. Dores e
ol s, conalia 3t lohus. Cias ukicies 10 260 xgos ot 020 s
Bacs Ua! st o). eget I8 TR CARALY 2 L85 MATes MRS SR0 SR UM 0 QISR ron i B!
& S 02 torminz Kool QU OF RS .
o
w
s
} i
cue.

Final Display:
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Donec sollicitudin molestie malesuada. Donec rutrum congue leo eget malesuada
Mauris blandit aliguet elit, eget tincidunt nibh pulvinar a. Curabitur arcu erat,
accumsan id imperdiet et, porttitor at sem.

Curabitur aliquet quam id dui posuere blandit. Pragsent sapien massa, convallis a
pellentesque nec, egestas non nisi. Donec sollicitudin molestie malesuada

TretrtaTTorTToHesitaTretstty mpus convallis quis ac lectus.

[Donec sollicitudin molestie malesuada. Mauris
plandit aliquet elit, eget tincidunt nibh pulvinar
5. Curabitur arcu erat, accumsan id imperdiet et,
joorttitor at sem. Cras ultricies ligula sed magna
dictum porta

estibulum ante ipsum primis in faucibus orci
uctus et ultrices posuere cubilia Curae; Donec
elit neque, auctor sit amet aliquam vel
Lillamcorper sit amet ligula. Vestibulum ante
psum primis in faucibus orci luctus et ultrices
pasuere cubilia Curae; Danec velit neque, auctor
kit amet aliqguam vel, ullamcorper sit amet ligula.
KCras ultricies ligula sed magna dictum porta
[Curabitur non nulla sit amet nisl tempus convallis

fquis ac lectus.

—_— — Nulla porttitor accumsan tincidunt. Proin eget
Joe Hefner is being used as an example of the ortor risus. Vivamus suscipit tortor eget felis
drop image joorttitor volutpat. Sed porttitor lectus nibh.

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque velit nisi, pretium

ut lacinia in, elementum id enim. Pellentesque in ipsum id orci porta dapibus.
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1.35 Tabs

Horizontal list of categories (tabs) that when clicked, open a pane of related content. Only
one tab’s content is viewable at a time.

Usage:

Displaying a large amount of related content in a compact way

More info:

The Tabs component does not require any information other than component name. The
component consists of text panels with no borders.
Tab names display above the panels and are separately by a bar; the currently viewed tab
is designated by a green horizontal line.
Tab sub-components provide the content for each Tab panel. Content is maintained in the
Rich-Text Editor with full use of toolbar.
Each Tab pane consists of a rich text WYSIWYG (“What you see is what you get”)
container. Any rich text content can be placed here.
Tabs are highly scannable, making it intuitive and easy to use.
Tabs text will wrap if all tabs do not fit on one line.
Tabs are displayed in the order in which they reside in the content tree.
Tabs are most suitable when:
o Categories number 2-9
Category names are relatively short
Categories are similar in nature
Categories fit in a single row of tabs
Tab contents can be split into a 2-column format — see page component “Two-column
Container in Tabs”.

O O O

Sub-component: Tab

Example:

Campus Activities MSU Research

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore
magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo
consequat.

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore
magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo
consequat.

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore
magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo
consequat.

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore

maana alioua Lt enim ad minim veniam auis nastrud evercitation ullameo labhoris nisi ut alioiin ex ea commado

STEPS: To add or modify the content (data) for the component:
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1. In Content Editor, locate the page in the content tree
2. On Page Components folder:
o To ADD new Tabs component: right-click Page Components folder, select Insert >
Tabs Component, and give it a unique name
o To EDIT existing Tabs component: click Page Components folder to expand, and

select Tabs Component

3. SAVE

4. Create one or more Tab sub-components — REPEAT for each Tab used:

O

P & Side Tabs Component

Right click Tabs Component in the Tree and select Insert > Tab

4 4 TjOS Comnnnent Tah CAanrans
Insert > & Tab
&3 Tab 5
. yy — o - 4 —~
E] Rich Texc Search [ InNsertirom template
E] Rich Text [ Duplicate
» [ tdbtest ® Delete
b [ mltest — Rename
» [ mctest Copying >
» [J NTLtest Sorting »
e TR
> LJ r|s test ,470 Edit o

Media Library Wor[J=EEGIE

o Name the Tab item

This name serves as a query string that is added to the page URL when a tab panel
is opened. The URL + query string can be used as a link to the page and to open a
specific tab panel.

Example: https://msu.qga.sitecore.msu.edu/page-name#2columnrichtext

Enter a name for the new item:

2 column rich te:<t|

ﬁ Cancel

In the right pane, modify fields in Tab Details section:
= Tab Title — text that displays as the Tab category
= Tab Content — use the rich text container to provide content.
Click “Show editor” to begin.

O
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Tab Details

Tab Title:

Tab

Tab Content:

Show editor Suggest fix Edit HTML

5. SAVE

6. Drag and drop Tabs in the content tree so that they are in the correct order for display

7. NEW Links List component only:

o In Experience Editor, add Tabs Component
o SAVE and close EE tab

8. In Content Editor, preview the page and verify changes made (optional) — on Publish
ribbon, select Preview

9. Publish the Tabs component.

10. Verify changes in a browser.
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1.36 Tabular Directory

Serves as a landing page where the visitor can view a list of items being featured on the site

Usage:

More info:

In tabular directory “Number of Columns to display” field — do not count the Description first
column in the count.

To display a table of all Tabular Directory pages, in Experience Editor, add “Tabular
Directory Page” component. Data Source is the Tabular Directory item itself. (In EE, no
table actually displays.)

One or more dropdown selectors are automatically displayed. They do not necessarily
correspond to the table columns. Their values represent values entered into column fields
in the individual Tabular Directory pages. Values are maintained in tenant global
Configuration > Tabular Categories.

Example:

STEPS: To create a Tabular directory page:

PN =

Right click on the “Home” node

Select “Insert” to expand the menu

Select Tabular Directory Page

Under the “Tabular Directory” section of the content editor you can define the “Number of items per
page”

You can then define the number of columns that you want your table to have (up to 8)
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»
4 |5 sitecore m

4 & Content

& Home Item ID:
» @ Giobal Configurations e name:
4 @ msu
Item path:
4 @ msu
4 % Ho T
> Insert » [ Page
> A
Search ™ Event Landing Page
<« :
> 23 [ Duplicate 1 News Repository
g -
» [ ® Delete & Redirect
O = Rename %% People Directory Page
» O Copying » | {§] Tabular Directory Page
» Sorting » [ Insert from template
Ll e oxper
» 1 & Edit
4 o |
0 @ Console Text - Please ent
by g Scripts X Show editor
> w % Refresh
b [N rarrimirhalaizianre Ermm = cinnle ~nnr

6. Finally, you can add the title for each column displayed on the table

Tabular Directory A

Number Of Items Per Page:

Number Of Columns To Display:
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1.36.1 Tabular Page

The tabular page is added below the Tabular Directory page. The tabular directory page lists the
information for each item based on the info populated into each item’s “Tabular Page”

To create a People details page:
1. Right click on the “Tabular Directory” node
2. Select “Insert” to expand the menu
3. Select Tabular Page

4. Enter the “Page title” which will also serve as the first column’s value for the item
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[

v Vv Vv Vv Vv Vv VvV Vv Vv v

r

f] Tabul

v 5 /
Insert » Tabular Page
B Pa _
‘ Q) Search [ Insert from template
[ testr
0 [f1 Duplicate Created from: [
test-t
lete
[) testr W Delete Item owner: s

— Rename
D a-teal

O Neeir  CoPY™B > e

™ testr Sorting ¥ iag
[) testr & Edit
[] Testj [T] Console
[ abou By Scripts »
(3 acade @ Refresh
(Y rons

» [ tdb-IT8 £

» [ test-michele-uatl

» [ test-michele-uat2

» [ test-michele-uat3

» [ tdb-IT82

< redirecttest
» 2% PDPage Naeim Test
» [ test-michele-events

» [ test-michele-training-1

4 [H] Tabular Directory UAT
[ff] Page Components

» [l Biochemistry

[ test-mc-publisher

[ test-tdb-publisher

[ test-michele-publisher-4

[} a-team uat

v v v v v

[ Naeim Newsletter subscribe test

5. You can input all of the

Page Title:

Tabular Directory

Navigation Title:

Ly oo T - T
Template: /sitecore/templates/Project/MSU/Pages/Tabular Page - {4569B9AC-4976-4FBA-BF2C-84150;
Created from: [unknown]

Item owner: sitecore\Aelsabagh

Page Title:
Biochemistry

Navigation Title:

Browser Title:

following fields for each Tabular Page item:

Column 1 to 7 (these will populate columns 2 to 8 respectively for that item in the table)
Category 1 to 3 (these will allow the user to filter and sort the items in the table)
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Column 1:

Online

Column 2:

Certificate

Column 3:

9

Column 4:

=]

Column 5:

Column 6:

Column 7:
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6. The tabular page can be populated with content by inserting these components under the
“Page components folder”:
a. Right click on the “Page components” folder
b. Select “Insert” to expand the menu
c. Select the desired component
d. Input the necessary information into the component
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. B e
Page Comoans

’ test u ek
» tes b
» Duplicate
» 8 Delece
4 Nasim News Renam =
» ™ test-michele Copying
» e chele Sorting
» Te Eg
»
»
»
»
»
- - T . - - -

Media Library Workbox

v) Ad-Coming Soon
[ Advanced Accordion
§ Advanced Mixed Content
@@ Carousel
=3 Hero Banner
=2 Hero Banner - Story

mighignt
[€] Image Facs
© InfoPanel
netroduction
L Links List
g Media

Media Contact

Tabular Directory Filter
» TextTAs

Inzertfrom template

1.36.2 Tabular Directory Categories

Sitecore CMS Components User Guide

The category fields of the Tabular page template allow the content author to define hidden

categories that can be used by the user to filter and sort between the table’s items.

These categories can be created and modified by Admins at this folder path (the path changes
based on the tenant you are working in):

[sitecore/content/MSU/MSU/MSU Configurations/Tabular Categories

STEPS: To modify the category, follow these steps:

1. Navigate to /sitecore/content/MSU/MSU/MSU Configurations/Tabular Categories

2. Select the Category that you want to modify

3. Enter a descriptive category title
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4 g MSU Configurations ) )
Item owner: sitecore\admin

» People Categories
» (& People Headers Data -~
4 Tabular Categories

Category 1 Title:

Course Type

Category 3

» @ Hero Banner Size

4. Add the category facets within the desired category folder by selecting “Category” from the

insert menu
4 Tabular Categories C
Categ~~-* '
Insert > *  Category
Categ
Q_ Search [ Insert from template |

m

[

L
oo

» &) HeroBal (1 Duplicate

» @ Settings ® Delee T
@ MSUToday =1 Rename
® Dictionary Copying »

i Glebal Compo Sorting »

@ Kirk Test 4 ] Console

>

»

»

» & Global Configt 7 Edit

>

» @ loundsna o Scrips i
» @ MSU New Site pve—

<]
» @ MSUWhitelabes Y.

5. Give the category facet a descriptive name

Message X

Enter a name for the new item:

Onling

ﬁ Cance‘
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» ] privacy = =
» [ research P
» [ sitemap-page Online
» [ social
» [ state-transparency-reporting Quick Info A
» [ students
» [ support-msu
ftem ID: {05BE2750-F731-4074-8590-81E2C134643A}
» [ visic
» { MSU Components Item name: Online
4 & MSU Configurations Item path: /sitecore/content/ MSU/MSU/MSU Configurations/Tabular Categories/Category 1/
» People Categories
Template: Isitecore/templates/Foundation/Shared/Configuration/Tabular/Category - {ECD33
» (@ People Headers
4 Tabular Categories Created from: [unknown]
« Gategory | ftem owner: sitecore\Aelsabagh

* Online

Category 2 Data A

Category 3
» (& Hero Banner Size Value:
» (@ Setings Ofilivia

» @ MSUToday
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1.37 Tabular Directory Filters
Description
Usage:
More Information:
e The content author can add a hero banner with filters linking to the tabular directory. This
makes it easy for the user to refine their selections and be directed to the tabular directory

with those filters applied.

Example:

STEPS: To create or modify the content (data) for the component:

1. Right click on the Page components folder of the page with the banner component.
2. Select Tabular Directory Filter from the insert menu

v v -

»

Phy ]
Web Davelopment et CTAS
@l Media Library  Workbox nsert from template I

In the right pane you can make modify the various fields.

Add the Desktop and Mobile background images.

Enter the Banner Title and Banner Description

You can modify the style of the banner such as adding a horizontal line or a gradient or
making the text dark.

o0k w
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7. You can then select which filters you want to display and what label you want for each filter

Note: The filters will appear in the order they are defined in the category configuration
folder, so make sure your labels follow the same order

Note: You can only display 2 filters at a time, so if 3 Categories are set to “Display” only the
first 2 will appear on the banner

8. Enter the text for the CTA that needs to appear on the banner and triggers the redirect once
the user selects it
9. Select the Tabular Directory page from the content tree in the “Tabular directory page field”

10. Save and Publish changes

The component can then be added onto a page within the Experience Editor:
1. Open the respective page in the Experience editor
2. Click on the “Component” icon in the toolbar
3. Click on the “Add here” button that corresponds to the placeholder where you want to insert
the banner
4. Select Tabular Directory filter from the “Select a Rendering” dialog box
5. Select the associated content data source that you created earlier
6. Save and Publish changes
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Select a Rendering
Select the rendering that you want to use. Cick Select to continue.

Carouse! Rich Text Side Tabs Signup Grid

S sose - -

Tzbular Directory Filter

[ Open the Proparties dialog box immediately. m Cancel

Select the Assodated Content

Select the content that you want to associate with the rendering and use as the data source.

Select an existing content item.

“ Sonee)
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1.38 Text CTAs

Multiple text links housed in a single page component, displayed on a solid gray
background.

Usage:
e Standalone text links that are not part of other content

More info:

e The Text CTA is a global component with a parent-child structure. Parent is the Text CTAs
and children are the CTAs.

¢ Maximum of 3 CTA sub-components are displayed. If more are created in the page
component, only the first 3 listed in the Tree under the component are displayed.
Bold and italic styles can be applied to the heading or to individual CTA links.

¢ |f Horizontal Line is selected, it displays between header and links. The line does not
display if a header is not specified.

Sub-component: CTA

Example 1: One CTA with header and arrow icon

NOT FINDING WHAT YOU'RE LOOKING FOR?

Explore more
MSU Facts =5

Example 2: Two CTAs, no header, with arrow icon
Source: MSU About page https://msu.edu/about

MSU Facts - History -

Example 3: Three CTAs with header and arrow icon
(“Meet our Researchers” illustrates style in hover mode)

GO DEEPER

Learn Explore our Meet our
about MSU o Academics = Researchers
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STEPS: To add or modify the content (data) for the component:

In Content Editor:

1.

In Content Editor Tree, navigate to page’s Page Components folder:

a. To ADD new component: right-click Page Components folder, select INSERT >
Text CTAs, and give it a unique name

b. To EDIT existing component: click Page Components folder to expand, and select
the Text CTAs component

v ] wi et

4 [[I] Page Comnnnant<
X Adial Insert » (¥ Ad-ComingSoon l
&) Conts 2 Search 5] Advanced Accordion
} @) Hero [0 Duplicate =@ Hero Banner
@) Highl ® Delete =3 Hero Banner - Story
EI Imagi = Rename @) Highlight
A Medi Copying » Image Facts
> & Side’ Sorting » [ Introduction
> & Tabs 2/ Edit @1 Links List
( %
i [T] Conscle (] Media
[E] Rich1
Bl Ric B§ Scripts » il Media Contact
5 Rich 7
@ Refresh & Mixed Content
E] Title- ceun oy
E2 Newsletter Subscribe
» [ bb_test
[ Photo-Caption Carousel
» [ faculty-staff
= & ote
» [ calendars 8. Quote
» [ campus-life B Rchiled
» [ celebrations & Side Tabs Component
» [ census2020 & Tabs Component
» [ contactus » TextCiAs

» | Insertfrom template

Media Library  Workbox

In right pane, modify fields in the Text CTAs section:

2.
3.
4

Header — enter text that displays above the links

Header Styles — (optional) select Bold and/or Italic to be applied

Horizontal Line — check to display a small green line between Header and links. (If no
Header, the line does not display.)

SAVE
To ADD a CTA link (max. 3):

a. Select the Text CTAs component in the Tree, right click the component, select Insert
> CTA, and give it a unique name
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P &f Dide 1aosLomponent

P & Tabs Component All
» T e
= Insert l) s CTA
| Ric
‘ Search [ Insert from template
E] Ric e

=] Tic [ Duplicate

» [ bb_te ¥ Delete

» [ faculty-staf ™ Rename

» [ calendars

~u

Copying »

7. Add/Edit CTA sub-component fields in the right pane — REPEAT for each CTA used:

a. Link:

i

ii.
iii.
iv.
V.

Vi.

Select link type

For Internal link, select a page from the Tree

For External link, enter fully specified path

Description — button label (the text that appears on the button)

Target — Active Browser (destination displays in same browser tab) or “New
Browser” (destination displays in new browser tab)

Click INSERT

b. Styles — optional styles for link text

c. Arrow Icon — check to display the Arrow Icon next to the link

Item owner

CTA

Link:

111111

] Arrow lcon

8. Save

9. Save and Publish your changes.
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10. NEW Text CTAs component only:

a. In Experience Editor, add Text CTAs component
b. SAVE and close EE tab

11. In Content Editor, preview the page and verify changes made (optional) — on Publish
ribbon, select Preview

12. Publish the page component.

13. Verify changes in a browser.
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1.39 Text Fact Data Source

Sitecore CMS Components User Guide

Store and maintain Text Fact items in the site’s global components node. Facts can be

used in Grid and Text Facts Grid components as the data source.

Usage:

More info:

¢ The Grid component and the Text Facts Grid component can use Text Facts as a data

source.

e Facts can be stored in the content tree or in sitename Components node.

Example:

STEPS:

» {2 Global Events

4 ] Global Facts

G 200A

& 5bitic 3

&l Alumte @
G Educ: %R

G Factd —m
5] Fact5

& Fact6

& Fact? 7
& Fact8 -
@ Fact9 .
5 Facult

& Facult, ...__.

Insert
Search
Duplicate
Delete
Rename
Copying
Sorting
Edit
Console
Scripts

Refresh

& Institutes and Centers

Quick Info

l G Fact

110D558f
[ Insert from template
Item name: Home
ltem path: /sitecorel/c
Template: /sitecorelt
»
Created from: [unknown
»
Item owner: sitecore\A
Data
»
il resea

Title - Please enter title of the |

Sitecore Experience Platforr
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EDCENDUCCEDEREDBEE oo :
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1.40 Text Facts
Display one or more predefined infographic Facts in a tiled (grid) layout.

Usage:
¢ Display one infographic Fact in a cell of the Grid component
¢ Display one or multiple infographic Facts in the Text Facts Grid component

More info:
¢ Facts content (items) must be created prior to adding or editing the Text Facts component.
e Facts content is located in the Tree at: sitename Global Components > Global Facts
e Factitems can be created prior to when they are needed. When ready to use, a Global
Fact item is selected in the page’s Text Facts component.
e Facts can be displayed in a grid — either the Grid component or the Text Fact Grid
component.
e Using the Grid component:
— Holds a single Text Fact item in one cell
— Other Grid cells need not contain Text Facts items
e Using the Text Facts Grid component:
— Holds one, two or four columns of Text Fact items
— An optional image can be displayed to the right or left of the Facts.
— Fact items can be displayed in the following formats:
o Image + 1 column of facts
o Image + 2 columns of facts
o Image + 4 columns of facts
o Noimage (1-4 facts)
¢ A Grid and its format option must first be set up in Experience Editor. Select the format and
add Fact items to the component; items are automatically arranged appropriately.

— Global Facts item —

Example 1: These items are stored in Global Components and sitename Components nodes

200+ 34

MSU programs Undergraduate and graduate
- . programs ranked in the top 25
Academic programs FRRERC It tOp nationally by U.S. News &

25 nationally World Report

— Using a Grid component —

Example 2: Text Facts in a generic Grid component https://msu.edu/academics
The cells containing the two Facts have green backgrounds.
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Academic programs

Undergraduate and graduate
programs ranked In the top 25
nationally by U.S. News &
World Report

— Using a Text Facts Grid component —

Example 3: Image (left) with 1 column of facts — single fact item
> W
)

Best College
Values

Example 5: Image with 2 columns of facts https://msu.edu/about
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TOP RANKINGS

No. 32

Top 100

Example 6: Image with 4 columns of facts

SCHOLARSHIPS  »

Example 7: No image, white background
All fields are used: Section Header, Section Description

63 78 No.11

World’s Most Influential World’s Most Influential World’s Most Influential
Universities Universities Universities
MIT Technoloigy Review MIT Technoloigy Review MIT Technoloigy Review =
according to a Wikipedia mining Lorem ipsum dolor sit amet, Lorem ipsum dolor sit amet,
algorithm consectetur adipiscing elit, sed do consectetur adipiscing elit, sed do
eiusmod tempor incididunt ut eiusmod mpor incididunt ut

labore et dolore magna aliqua. Ut labore et dolore

enim ad minim veniam

STEPS: To add or modify the content (data) for the component:

(Be sure that new Global Facts items have been created before starting.)
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— Using a Grid component —

Complete these steps if using a Grid component to hold the Fact item(s).
See Example 2 above.

If using a predefined Fact from sitename Components, create the Fact before creating the
component.

1. In Content Editor, select the page in the content tree.

2. Navigate to Experience Editor: Publish ribbon > Experience Editor

3. Create a Grid component if one does not already exist

4. Click the Grid component, then click “Add here” inthe desired cell of the Grid. Rememberthat
facts canonly be addedto “small” cells.

Academic Programs

5. Select “Text Fact” rendering in the dialog box.
6. Choose one of these data source options:

a. Select a Text Fact component created in Content Editor

b. Select a Global Fact item from the list of all site Global Fact items

c. Select Create New Content (content will display in Content Editor Tree)
7. Select Background Color.

Control Properties

Background Cole
v
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8. SAVE

9. Close the EE tab and return to Content Editor tab

10. In Content Editor, preview the page and verify changes made (optional) — on Publish
ribbon, select Preview

11. If you selected “Create New Content”, click that component added in EE and enter content.

12. Publish the page component.

13. Verify changes in a browser.

— Using a Text Facts Grid component —

Complete these steps if using a Text Facts Grid component to hold the Fact item(s).
See Examples 3-7 above.

In Experience Editor:

1. To ADD a new Text Facts Grid component:
a. Create a Text Facts Grid component
b. On Control Properties (displayed automatically) in Grid Layout field, select a format
from the dropdown list:
— Image and 1 Column of Facts
Image and 2 Columns of Facts
Image and 4 Columns of Facts
— No image

2. To CHANGE an existing Text Facts Grid component: click “More” and select “Edit
component properties”.

3. In section Text Facts Grid, set the following fields:
i. Grid Layout — select a formatting option in the dropdown
ii. Background color — select green (default) or white
iii. Image on Right — check to display image to the right of Facts items, uncheck to display
on left
iv. Click OK

4. Select the Associated Content: click “Create New Content”, give it a unique name (e.g.
text-facts), and click OK.

SAVE
Close the EE tab and return to Content Editor tab

5.
6.
In Content Editor:
7. In the Content Editor Tree, navigate to the page, click Page Components folder to expand,
and select the new Text Facts component.
Note: If Grid is not in the Tree, collapse and expand Page Components folder to refresh.
In the right pane, modify fields in the Text Facts Grid section:
8. Section Header — enter text that displays above the Facts

9. Section Description — (optional) enter text that displays below header
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10.

11.

12.

13.

14.

15.

16.

17.

18.

19.

Green Line — check to display a small green line between Header and links. (If no Header,
the line does not display.)

Photo — click Browse and select an image from Media Library (not required if the No Image
format was selected for the Text Facts Grid)

Facts Selection:

Select all Facts from the list box that should display in the Grid.

Facts are displayed in the order placed in the Selected list box.

Use Search to locate Facts by any text in the Facts Title (but not in Subheading).
Contents of the Facts Selection list box are all Facts entries in the Global Facts
component.

coow

Text Fact Style — select component Header style from dropdown: Prominent (default),
Regular Heading, Small Heading

Featured Fact — from the list of Global Facts, select one Fact that is displayed first if
multiple Facts are used (default is None)

Featured Fact Style — select Facts first line style from dropdown: Prominent (default),
Regular Heading, Small Heading

SAVE
Preview the page and verify changes made (optional) — on Publish ribbon > Preview
Publish the page component.

Verify changes in a browser.
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1.41 Two-column Container in Tabs
Description
Usage:

More information:
¢ The content author can split the body of a page within a tab into 2 columns by using the

Two column container tabber. The left column spans 66% of the page’s width, and the right
column spans 33% of the page’s width. The two-column container needs to be added from
the Experience Editor. It can be added like any other component. Once a tabs component
is added, the two-column container can be added within one of the tabs’ placeholder. Once
the 2-column container is added, you will see the “Add here” label for each of the two
columns of the container whenever you click the Add Component icon. Make sure you
Save and Publish the changes.

Example:

STEPS:

Tab 2

Sed ut perspiciatis unde omnis iste natus error sit voluptatem accusantium doloremque laudantium, totam rem aperiam eaque ipsa,

quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt, explicabo. Nemo enim ipsam voluptatem, quia voluptas sit,

_I Mt aut fugit, sed quia consequuntur magni dolores eos, qui ratione voluptatem sequi nesciunt, neque porro quisquam
osum, quia dolor sit, amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt, ut labore et

= ; 7
2 ¥ liguam quaerat voluptatem.

Usage: 1

* Add here

Select a Rendering O X
Select the rendering that you want to use. Cick Select to continue.

Opzn the Properties dislog box immediately ﬁ Cancel
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The following components can be added in the left column:

The following components can be added in the right column:

Tab 1

Rich Text Component

Tabs component

Advanced accordion

Mixed content

Highlight

Links List

Media contact

Single mixed content with social media
Text facts grid

Media

Aside component

Sitecore CMS Components User Guide

Sed ut perspiciatis unde omnis iste natus error sit voluptatem accusantium doloremque laudantium, totam rem aperiam eaque ipsa,
quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt, explicabo. Nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores e0s, qui ratione voluptatem sequi nesciunt, neque porro quisquam
est, qui dolorem ipsum, quia dolor sit, amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt, ut labore et
dolore magnam aliquam quaerat voluptatem.

#+ Add here

*+ Add here

+ Add here
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1.42 Two-column Grid 66-33

Description
Usage:

More info:
¢ The content author can split the body of a page into 2 columns by using the Two column

grid 66-33 container. The left column spans 66% of the page’s width, and the right column
spans 33% of the page’s width. The two-column container needs to be added from the
Experience Editor. It can be added like any other component. Once a two-column
container is added, you will see the “Add here” label for each of the two columns of the
container whenever you click the Add Component icon. Make sure you Save and Publish
the changes.

Example:

STEPS:

The following components can be added in the left column:

Rich Text Component

Tabs component

Advanced accordion

Mixed content

Highlight

Links List

Media contact

Single mixed content with social media
Text facts grid

Media

The following components can be added in the right column:

e Contextual navigation
e Social Share
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Select a Rendering

Select the rendering that you want to use. Click Select to continue.

_— N s 2
= B
— ==

Signup Grid Single Mixed Content Social CTA Tabs Component
With Sccial Media

/S

Text CTAs Text Facts Grid TwoColumnContainer_66_

[[] Open the Properties dialog box immediately. E Cancel

N\ Add here N\ Add here
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2 Site-level Components

Site-level components are shared between multiple pages. For example, the Header and Footer are
shared on every page in a site. A Contextual Navigation component is shared by the pages that are
listed in the contextual navigation.

Shared components allow changes to be made in one place and immediately displayed wherever the
shared components are used.

2.1 Header

The Header is the top area of every page of the website. It displays above the breadcrumb links
and the page content.

For: Parents | Students | Alumni | Faculty & Staff

About Admissions | Academics

The Header consists of:
e Brand Bar
e Masthead and Site Name
e Main Navigation and Mega Nav

Header example: https://msu.edu/

For: Parents | Students | Alumni | Faculty & Staff Apply | Visit | Give

Search for peopie, places and more Q

About | Admis ns | Academics Research Campus Life | Athletics

Header example: https://comms.msu.edu/

ﬁ MICHIGAN STATE UNIVERSITY Apply | Give | Visit

University Communications

What We Do | Who We Are | Resources

2.1.1 Brand Bar

The Brand Bar is available to display on every Sitecore website. It consists of a list of text links that
display above the masthead.
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The Brand Bar is optional. Content is determined by the site owners.

The Brand Bar has two types of links:
e Audience link — left-justified, displays in content tree with green arrow icon
e Global CTA - right-justified, displays in content tree with blue arrow icon

Example of Header in Content Editor content tree:

4 ] Admissions Header
» == Main Navigation
4 [7] Brand Bar
= Apply
B Visit
B Give
7] Masthead

{Z] Admissions Info Panels

To modify the Brand Bar:

1. In Content Editor, in the content tree locate this node: sitename Global Components >
sitename Header > Brand Bar

2. Click right arrowhead of Brand Bar node to expand it.

3. To ADD alink:

a.

b.
C.
d

o0

Right click Brand Bar in content tree.

Select Insert and choose the type of link to add — Audience or Global CTA.
Give it a name and click OK.

In the right pane (main content area), insert the link by clicking the appropriate
option (e.g. Insert Link for internal links or Insert external link for external links).
Fill in the “Description” field — (required) this displays as the link label.

Save and publish the changes.

4. To CHANGE Audience or Global CTA text:

a.
b.
C.

Click right arrowhead of Brand Bar node to expand it.
Click a Brand Bar link to select it.
In the right pane, click the link label and change the text, then click OK.
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B3 -

E) Students

Quick Info

Enter a new name for the item:

Item ID: {2F6A2707-58C6-45D3-BB9F- | Students

Item name: Students

Item path: /sitecore/content/MSU/Globa

2.1.1 Masthead and Site Name

The Masthead contains the site name (which serves as a link to the site’s Home page), the MSU
search tool, and the MSU Helmet icon and MSU Wordmark (logo) image (which acts as a link to
the main MSU.edu website).

More than one Masthead item can be created and stored in the site’s Components node in the
“sitename Header” item. However, only one masthead is active at any time.

2.1.3 Main Navigation and Mega Nav

Main Navigation has two sections:
e Navigation Bar — primary navigation links arranged in a horizontal menu bar
¢ Mega Nav — (aka Super Nav or Mega Menu) links related to a main navigation item

Main Navigation example: https://msu.edu/
e Primary navigation links: About, Admissions, Academics, Research, Campus Life and
Athletics.
“MSUToday” is a right-justified main navigation link with its own style.
Mega nav links for the About section: Overview, MSU Facts, History, etc.
Columns 1 and 2 are text links.
Column 3 is an optional CTA link with image.
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For: Students | Alumni | Faculty & Staff Apply | Visit | Give

About | Admissions | Academics | Research | CampusLife | Athletics MSUToday

Overview Leadership
MSU Facts Diversity & Inclusion
History Spartan Success

Visit Mission Statement

MSU’s plan to keep Spartans
safe

Learn More —»

Navigation Bar (Nav Bar)

The Nav Bar has two types of links: Regular and Aligned Right. These types each open their own
variation of the Mega Nav.

The regular Nav Bar items open a Mega Nav that has up to 3 columns of links and an optional
column with a single CTA.

The Aligned Right Nav Bar ltem opens a Mega Nav that has a column of up to 3 CTAs and a single
column of links.

Mega Nav
Hovering over a primary navigation link will expand the corresponding Mega Nav if present.
External (outbound) links (e.g., Athletics) may not have a Mega Nav and do not have a hover state.

Clicking a link within the Mega Nav takes the visitor directly to that page.

Content tree items:

4 ] MSU Header
4 == Main Navigation
4 @ About
» [@ Column1
» [@ Column2
= CTA
Admissions

Academics

Campus Life

v v v v v

MSU Today

a
@
@ Research
a
a
Q

Athletics
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To add a Nav Bar link:

1. In Content Editor, locate the Nav Bar node: sitename Components > sitename Header >
Main Navigation

2. Right click, select Insert > Main Navigation Link

{J MSU Events == Vain Navigation

(] MSU Footer

4 ) MSU Header

4 == Main Navigation 3§ The currght item does ni
> = Insert » @ Main Navigation Link
a !\ Search 1 Insert from template

@ [0 Duplicate 3
» m R Delete 1 Item ID: {D6C7EACA-68
Mm Rename B T e Alnin Alauimnbis

3. Give it a name and click OK. This name is NOT what appears in the Nav Bar.

Enter a name for the new item:

{D6C7EACA-68

Main Navigation

it item does n¢

4. In the right pane, add the Link.
Be sure to fill the “Description” field as this is the text that appears in the Nav Bar. The link
can be Internal or External. If you are selecting an Internal page link, the page must have its
“Include in Navigation” checkbox selected.

5. If you are adding a Right Aligned item, select the “Is Aligned Right” checkbox. Fill the “CTAs
Title” as this is the title for the CTA column.

6. Save and publish the changes.
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;- B

Item path:

Template:
Created from: [unknown]

Item owner: sitecore\Admin

Main Navigation Link

Is Aligned Right

Link:

IMSUIMSUToday/Home

CTAS Title:

To add a link to the Mega Nav for a Nav Bar item:

1. In Content Editor, in the content tree locate sitename > sitename Components > sitename
Header > Main Navigation

2. Right click the desired Nav Bar item, select Insert and choose either Column or CTA.

3. Give it a name and click OK.
This name does NOT appear in the Mega Nav.

4. To add Column Links you first need to add a Column.

4 {Z) MSU Header S

4 == Main Navigation

4 @ Main Navigation Link 1 R s L
» & Colurr Insert » [@ Ccolumn
p igation Link
» @ colur Search ® C(TA
® ctA [0 Duplicate [ Insert from template  /content/MSL

@ MainNay 3 Delete Template: /sitecore/templates/F

@ MainNan = Rename

mSTTAE S S (SCEie o

5. Select the Column you wish to add Links to. Right Click and select Insert>Column Link
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Column Link 2

/sitecore/content/MSU/MSL

lsnecojemplates/FoLx nda
]

sitecore\Admin

4 _J MSU Header Item name:
4 == Main Navigation
Item path:
4 B Main Navigation Link 1
2 B Coll TeEmprate:
e Insert » & Column Link
=G
. Search Insert from template
5 C
[ Duplicate Item owner:
» (B Col
R Delete
= CTA
Rename
@ Main N
- el Conving » Linbe

6. Give it a name and click OK.
This name is NOT what appears to the visitors.

7. Inthe right pane, add the Link. Make sure to fill the “Description” field as this is the text that
appears in the Mega Nav. The link can be Internal or External. If you are selecting an
Internal page to link to, the page must have its “Include in Navigation” checkbox selected.

8. To add a CTA to the Mega Nav, select the Nav Bar item, right click and select Insert > CTA.

9. In the right pane, add the Image, Text, and Link. If the Nav Bar item is Aligned Right, also
fill in the Date field. For the Link, make sure to fill the “Description” field as this is the text
that displays as the CTA label. The link can be Internal or External. If you are selecting an
Internal page to link to, the page must have its “Include in Navigation” checkbox selected.

CAMPUS SAFETY
INFORMATION AND
RESOURCES

Text:

text 3
T /)nly for Aligned Right Nav Bar item

date 3

Link:

MSU/MSUToday/Home

10. Save and publish the changes.
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2.2 Footer
The Footer is the bottom area of every page of the website. It displays below all page content.

The Footer consists of two parts:

e Mega Footer
o Footer
o Footer Links
o Footer Contacts
o Footer Social Media
o Footer CTAs

e Legal Footer (aka Footer Secondary)

ﬁ MICHIGAN STATE UNIVERSITY

BRAND AND IDENTITY MEDIA
COMMUNICATIONS

ADDITIONAL
RESOURCES

Contact us

Brand studio

Campus Media Guidelines University Licensing

Branded tempiates
Policy on Endorsement, Address
and Advertising.

Experts directory
Boilerplate text

Guidelines for unit communicators
MSU Editorial Style Guide

Grapl
Graphic elements Copyright Permissions Center

Logos and marks
Logo usage chart

Signature loga generator for MSU
units

Media Relations Procedures

Op-ed Guidelines

FOR MEDIA

ool Kit Requests
Issues & Statements

ons Toolkit for

WEB, SOCIAL, PHOTO &
VIDEOD

Filming at MSU
MSU Web Standards

Photo Guidelines

MSU phatos
Social @ Michigan State

Social Medis Directory

FOLLOW US

If you're having accessiility issues, please let us know.

Contact Information | Site Map | Privacy Statement | Site Accessibility

MICHIGAN STATE
ONIVERSITY

Footer Secondary
AKA Legal Footer

Call MSLL (517) 3559855 | Vst mausdla | Netics of Nordiscrimination
SPARTANS WILL | € Mcigan State Unbsarsiy

To modify any part of the Footer, in Content Editor’s content tree, navigate to sitename
Components > sitename Footer.

Footer links are in the site’s Footer node.
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2.2.1 Mega Footer
The Mega Footer has a dark green background. Much of the content can be modified.

Mega Footer sections as they display in the content tree:
Footer

Footer Contacts

Footer CTAs

Footer Links

Footer Social Media

2.2.1.1 Footer Contacts

The Footer Contacts node contains these site-level items:
e Phone
e Address

To modify Footer Contacts:
1. Right click Footer Contacts node and select Insert > Contact Us
2. Give it a name and click OK
3. In the right pane, fill in the Title and Description.
4

Optionally you can add a link by clicking on the appropriate option (e.g. Insert Link for
internal links or Insert external link for external links)

Adding a link turns the Description into a clickable link

6. To have an item display as a button, select the “Display As Button” checkbox.
The value in the “Description” field is used as the button label.

7. Save and publish the changes.

o

2.2.1.2 Footer Links

Footer links display in three columns. A maximum of three columns is advised. Under each
column a maximum of two sections is advised. Links must be added under sections with short
concise link text so that links do not wrap extensively.

”

Link names do not have to be “Link One”, “Link Two”, etc. They can be more descriptive, such as

L]

“Tech Support”, “Events Calendar”, etc.

Content tree:
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4 [@] Footer Links
4 [g] Column1
4 [® Column One
&> Link One
&> Link Two
5> link-test
&> Link Three
» [g] Column2
» [g] Column3

To add a column:
1. Right click Footer Links to expand.
2. Select Insert > Column
3. Give it a name.

A Item name: Link 1
3 CTA1
o CTA2 Item path: /sitecore/cor
4 1% Footer Linke 2 x
. pcora/ten
» 1S 4 |
1@ co Insert s Column
4 B 4 Search [0 Insert from template _ 1onknownl
i [ Duplicate Item owner: sitecore\Ad
i 8 Delete
! = Rt‘nJlT!‘{l _
| Copying >
Link:
N -
4 8 Co Sorting »
ert link ysert media link
« B 7 Edit
{ https://msu.st
&% Refresh
= Link 2 -

To add a Column Section under a Column:

SEr m

4 [®) Footer Links

4 |g] Column?
Insert » [® Column Section 283214-C5!
A ﬂ] Sel
> Search "1 Insert from template -
., [ Duplicate
- Item path: /sitecore/contg
= ® Delete
&
@ © Rename Template: /sitecore/temg
4 [g) Colun Copying » Created from: [unknown]
- _
4 5] Se Sartng 4 Item owner: sitecore\Adm
s Z Edit

1. Right click the desired Column
2. Select Insert > Column Section
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w

Give it a name. This name does not display in the footer.
Click the Column Section

5. In the right pane, enter a value in the Title field.
This is the section title displays in the footer.

6. Anicon can also be added to the left of the title by selecting an icon file in the Icon field

»

Item name: Column One

Item path: /sitecore/content/MSU/Admissions/Admissions Components/Admissions Footer/Footer Link
Template: /sitecore/templates/Foundation/Shared/Navigation/Footer/Column Section - {FBEOF413-8A4
Created from: [unknown]

Item owner: sitecore\tdb

Column Section A
Title:

Column One

m
[
a
ﬁ.
]
)
n
.
.

Browse Properties Open media library

/System/Channel Images/ch-customer-service

To add a link under a Column Section:

1. Right click the desired Section
2. Select Insert > Column Link
3. Give it a name. This name does not display in the footer.

4 g FOOTEr LIAS

Item ID: {7738B5E3A-FE!
3 CTAd
N rra Item name: Section |
o CTA2
4 |3 Footer Links Item path: /sitecore/conte
4 g Column1 A
& . Template: /sitecore/termng
- ~
4 |%] Sectior
Insert » & ColumnLink owif)
= Linl
Search Insert from template
= Linl areVAdm
Duplicate
& Linl
Column Section
L |
i B Cotiitiis Rename
Title:
4 [B sectio Copying
& Linl Sorting » Facilities & Resources
W Linl & Edit
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4. In the right pane, insert the link by clicking on the appropriate option (e.g. Insert Link for
internal links or Insert external link for external links)

5. Remember to fill the “Description” field as this text will be the displayed label for the link

Item 1D: (0CEDSBRS-BATS-4D47-ABBF776D44BLAAC)

Item name: Link 1

Item path /sitecorefcontent/MSU/Global Components/Glabal Footer/Foater Links/Column 1/Section 1/Link 1

Template: /sitecoreftemplates/Foundation/Shared/Navigation/Footer/Column Link - {2 1D0D9B2-6880-4D0C-8A3D-8CF759078845)
Created from:  [unknown]

Item owner: sitecore\Admin

et link =1 medla =t external ik ert anche &t ama 21T Ay W Clea

6. Save and publish the changes.

2.2.1.3 Footer CTAs

It is recommended that the footer have no more than two CTAs. If adding more, make sure that the
additional CTA does not break the layout of the footer.

To ADD a CTA:
1. Right click Footer CTAs node

» & Footer Contacts

4 |:g Footer CTAs

0

Insert » g CTA tifem does

g CT#

2z 4 Search [7 Insert from template -
» @ Footer [ Duplicate

» [ Footer ¥ Delete

Item ID: {1B19D3EC-
4 () Footer == Rename
Y Soc Copying > Item name: Footer CTAs
Y Soc Sorting 4 Item path: /sitecore/co
» {J Global H¢ ‘/" Edit
Template: /sitecore/tet

» ) Global Pl @ Refresh

2. Select Insert > CTA
3. Give it a name.

To modify a CTA:

1. Click a CTA in the content tree in the Footer CTAs node.
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2. In the right pane, modify the image and the link.

Image:

wse Properties Open media library Edit image Clea Refresh

/Images/MSUToday/KNOWmore-green-2

CAMPUS SAFETY
INFORMATION AND
RESOURCES

Link:

Insert media link nsert external link nsert anchor nsert ema nsert javascript Foliow Clear

/MSU/MSUToday/Home

2.2.1.4 Footer Social Media

Social Media icons reside in the Global Confirmations > Icons > Social Media lcons and must be
modified by a Sitecore Administrator.

Example: Social Medial icons are displayed above the footer, below the “FOLLOW US” heading.
A new site is created by default with the social links and icons used by the MSU main website.

The site owner can use the default MSU values, replace them with site-specific links and
corresponding icons, or remove social media links altogether.

FOLLOW US

00000

If you're having accessibility issues, please let us know.

M l C H I ( ;AN STATE Contact Information | Site Map | Privacy Statement | Site Acce

Call MSU: (517) 355-1855 | Visit: mswedu | Notice of Nondiscrimination

U N I V E R S I T Y SPARTANS WILL. | © Michigan State University

To modify the title of the Footer Social Media:
1. Select Footer Social Media in the content tree.
2. In the right pane, modify the title.
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3. Modify the text and link for Accessibility
4. Description field for the link is used as the link label in the footer.

B

Item owner: sitecore\Admin

Footer Social Media

Title:

Follow Us

Accessibility

Text:

If you're having accessibility issues,

Link:

Insert link Insert media link Insert external link nsert anchor nsert ematl

aScript Follow Clear

/MSU/MSUToday/Home

To add Social Media Link to the footer:

1. On Footer Social Media node, right click and select Insert > Social Media Link
2. Give it a name.

» Link 2 . .
0 Footer Social Media
409 Footr=T=——va=—ti
Insert > Y Social Media Link
3 Sc
Search | 7 Insert from template
P Sc ~
[ Duplicate Follow Us
» {J Globalt
® Delete

» J Global |
b & Globalcor — Rename Accessibility

3. Select the Social Media Link and in the right pane select the icon and insert the link.
The link for social media must be External as it will be pointing to the account on the
associated social media platform.

4. Save and publish the changes.
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Item owner: sitecore\Admin

Social Media Link ~

2.2.2 Legal Footer (aka Footer Secondary)

The Legal Footer has a white background. It is composed of the MSU Logo and three rows
containing links mandated as part of the MSU brand standards. All MSU websites must use the
Legal Footer, it is not just a Sitecore requirement.

With a few minor exceptions noted below, the content, style and layout cannot be modified.

The Legal Footer has one section in the content tree:
e Footer Secondary

The MSU Wordmark (logo) should not be changed.

To see the content, click the left arrowhead of Footer Secondary in the content tree to expand it.

MICHIGAN STATE
UNIVERSITY

Each row has multiple links.
The Row content should not be changed except where noted below.
To see the content, click the left arrowhead of Footer Secondary in the content tree to expand it.

Click the left arrowhead of each “Row” in the content tree to expand it.

Row 1 contains text and four links required by MSU brand standards:
¢ Contact Information — link may be changed to point to the site’s Contact page
¢ Site Map — link may be changed to point to the site’s Site Map page
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e Privacy Statement — MSU standard privacy information
o Site Accessibility — MSU standard accessibility information

Row 2 contains text and four links required by MSU brand standards:
¢ Phone — the main MSU telephone number
e Visit — provides a link to the main MSU website
¢ Notice of nondiscrimination — link to full statement of MSU’s nondiscrimination policies

Row 3 contains text and text required by MSU brand standards:
e Spartans Will — text tagline
e Copyright — copyright symbol and MSU text
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3 Global Components

Global components may be used by any Sitecore site.
Use with caution as the content may be changed or removed without notice.

Do NOT use the Global Header or Footer. Always use what is been set up specifically for each
site.

Other global components may be used at site owner’s discretion. Content is of a more general
nature, as opposed to being specific to a site or unit. Examples:

Global Authors and Global Contacts may be used in Story Pages for any site.

Global Facts are general MSU informatics and can be used in any site’s Text Facts or Image Facts
components.

Global Places may be used in any site’s components that provide a Place field.
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